FreeSWITCH: Fix issue with Big Endian compilation and sync to FS latest
[feed/telephony.git] / net / freeswitch / Makefile
index c18f5fd..b3b14cd 100644 (file)
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
 
 
 PKG_NAME:=freeswitch
-PKG_DISTNAME:=$(PKG_NAME)_git
-PKG_VERSION:=1.5.2b
+PKG_SOURCE_PROTO:=git
+PKG_DISTNAME:=$(PKG_NAME)_$(PKG_SOURCE_PROTO)
+PKG_VERSION:=1.5.5b
 
 
 #
-# The latest FS git hash in PKG_SOURCE_VERSION can be obtained from http://fisheye.freeswitch.org
+# The latest FS git hash in PKG_SOURCE_VERSION can be obtained from
+# http://fisheye.freeswitch.org
 #
-PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=bd2862080c7f55450a99b5565650c8300512a59a
+FS_DEFAULT_HEAD:=3ec15cce68852fd4dba7336dd7a7a505d143a111
 FS_LATEST_HEAD:=$(if $(DUMP),$(FS_DEFAULT_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD | cut -f1))
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_PULL_CURRENT),$(FS_LATEST_HEAD),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
@@ -168,6 +169,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_FS_WITH_BUILTIN_ZRTP \
        CONFIG_FS_WITH_FIXED_POINT \
        CONFIG_FS_WITH_IPV6 \
+       CONFIG_FS_WITH_LZMA \
        CONFIG_FS_WITH_MYSQL \
        CONFIG_FS_WITH_ODBC \
        CONFIG_FS_WITH_OPT \
@@ -190,14 +192,14 @@ define Package/$(PKG_NAME)/Default
   CATEGORY:=Network
   SUBMENU:=Telephony
   URL:=http://www.$(PKG_NAME).org/
-  MAINTAINER:=Mazilo <openwrt.forum.mazilo@recursor.net>
+  MAINTAINER:=Mazilo <openwrt.mazilo@recursor.net>
 endef
 
 
 define Package/$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   TITLE:=FreeSWITCH open source telephony platform ($(PKG_SOURCE_VERSION_SHORT))
-  DEPENDS:=+libcurl +libiconv-full +libjpeg +libncurses +libpthread +librt +libstdcpp +FS_WITH_POSTGRESQL:libpq
+  DEPENDS:=+libcurl +libiconv-full +libjpeg +libncurses +libpthread +librt +libstdcpp +FS_WITH_POSTGRESQL:libpq +libuuid
   MENU:=1
 endef
 
@@ -216,40 +218,50 @@ define Package/$(PKG_NAME)/config
     bool "Pull the latest git HEAD - $(PKG_SOURCE_VERSION_SHORT) (Press < Help > for more information)"
     default n
     help
-       This existing git HEAD ($(FS_DEFAULT_HEAD)) is probably outdated. 
-       Enable this option for the latest git HEAD ($(FS_LATEST_HEAD)). 
-       Enable this option ONLY if you know what you are doing. It may and/or may not be cleanly 
-       compiled and may require some intervension to create new patches. If you take this route
-       and come up with some patches, please contemplate to contribute or send in your patches.
+       This existing git HEAD ($(FS_DEFAULT_HEAD))
+       is probably outdated. Enable this option for the latest git HEAD
+       ($(FS_LATEST_HEAD)) ONLY if you know what
+       you are doing. It may and/or may not be cleanly compiled and may
+       require some intervension to create new patches. If you take this
+       route and come up with some patches, please contemplate to contribute
+       or send in your patches.
 
     config FS_WITH_ALSA
     depends on PACKAGE_$(PKG_NAME)
     bool "Enable ALSA for sound support"
     default n
     help
-        Compile $(PKG_NAME) with ALSA support.
+       Compile $(PKG_NAME) with ALSA support.
 
     config FS_WITH_BUILTIN_ZRTP
     depends on PACKAGE_$(PKG_NAME)
     bool "Enable built-in ZRTP"
     default y
     help
-        Compile $(PKG_NAME) with ZRTP support.
+       Compile $(PKG_NAME) with ZRTP support.
 
     config FS_WITH_IPV6
     depends on PACKAGE_$(PKG_NAME)
     bool "Enable IPV6 support in APR"
     default y
     help
-        Compile libs/apr package with IPV6 support.
+       Compile libs/apr package with IPV6 support.
+
+    config FS_WITH_LZMA
+    depends on PACKAGE_$(PKG_NAME) && PACKAGE_liblzma
+    bool "Enable liblzma usage in libtiff"
+    default y
+    help
+       Compile libs/tiff package with liblzma support. This option requires
+       LZMA2 compression package called liblzma.
 
     config FS_WITH_OPT
     depends on PACKAGE_$(PKG_NAME)
     bool "Enable optimization"
     default y
     help
-       Compile $(PKG_NAME) with optimization flag enabled. This will add max optimising
-       compiler flags
+       Compile $(PKG_NAME) with optimization flag enabled. This will add
+       max optimising compiler flags
 
     config FS_WITH_SCTP
     depends on PACKAGE_$(PKG_NAME)
@@ -257,7 +269,7 @@ define Package/$(PKG_NAME)/config
     default y
     select PACKAGE_sctp
     help
-        Compile $(PKG_NAME) with SCTP support.
+       Compile $(PKG_NAME) with SCTP support in lib APR.
 
     config FS_WITH_MYSQL
     depends on PACKAGE_$(PKG_NAME)
@@ -265,14 +277,14 @@ define Package/$(PKG_NAME)/config
     default n
     select PACKAGE_libmysqlclient
     help
-        Compile libs/apr-util with MySQL.
+       Compile libs/apr-util with MySQL.
 
     config FS_WITH_POSTGRESQL
     depends on PACKAGE_$(PKG_NAME)
     bool "Compile apr-util (also enable $(PKG_NAME) core) with PostgreSQL support"
     default n
     help
-        Compile both libs/apr-util and $(PKG_NAME) with PostgreSQL support.
+       Compile both libs/apr-util and $(PKG_NAME) with PostgreSQL support.
 
     config FS_WITH_SQLITE3
     depends on PACKAGE_$(PKG_NAME)
@@ -280,7 +292,7 @@ define Package/$(PKG_NAME)/config
     default y
     select PACKAGE_libsqlite3
     help
-        Compile libs/apr-util with SQLITE3.
+       Compile libs/apr-util with SQLITE3.
 
     config FS_WITH_ODBC
     depends on PACKAGE_$(PKG_NAME)
@@ -589,10 +601,11 @@ CONFIGURE_ARGS+= \
        $(if $(CONFIG_FS_WITH_SQLITE3),--with,--without)-sqlite3 \
        $(call autoconf_bool,CONFIG_FS_WITH_IPV6,ipv6) \
        $(call autoconf_bool,CONFIG_FS_WITH_OPT,optimization) \
-       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-erlang-event),--with-erlang,--without-erlang) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-celt),--with-ogg="$(STAGING_DIR)/usr",--without-ogg) \
        $(if ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-curl)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-cdr)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-curl)),--with-libcurl="$(STAGING_DIR)/usr",--without-libcurl) \
+       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-erlang-event),--with,--without)-erlang \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-java),--with-java="$(STAGING_DIR)/usr",--without-java) \
+       $(call autoconf_bool,CONFIG_FS_WITH_LZMA,lzma) \
        $(call autoconf_bool,CONFIG_FS_WITH_POSTGRESQL,core-pgsql-support) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp && CONFIG_FS_WITH_FIXED_POINT,fixed-point) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp,builtin-tiff) \
@@ -645,6 +658,7 @@ CONFIGURE_VARS+= \
        apr_cv_type_rwlock_t="yes" \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-perl),ac_cv_path_PERL="yes",) \
        libzmq_cv_cxx_werror_flag="" \
+       ac_cv_cflags_warn_all_ansi='-Wall -std=c99 -Wno-unused-variable' \
 
 
 define Build/Prepare
@@ -1028,9 +1042,9 @@ $(eval $(call BuildPlugin,mp4,MP4 File Format Support For Video,vanilla,,,,@BROK
 $(eval $(call BuildPlugin,mp4v,MP4 CoDec Support For Video,vanilla,,,,))
 $(eval $(call BuildPlugin,native-file,WAV Format Sound Player,vanilla,,,,))
 $(eval $(call BuildPlugin,nibblebill,Credit / Debit Billing,vanilla,,,,))
-$(eval $(call BuildPlugin,oreka,Media Recording with Oreka,vanilla,,,,))
 $(eval $(call BuildPlugin,openzap,Zaptel (Superseded by FreeTDM),libs,ozmod,lib/libopenzap lib/pkgconfig/openzap,,+libpcap))
 $(eval $(call BuildPlugin,opus,Opus CoDec,vanilla,,,,))
+$(eval $(call BuildPlugin,oreka,Media Recording with Oreka,vanilla,,,,))
 $(eval $(call BuildPlugin,portaudio,Portaudio To Sound Card Interface,vanilla,,,alsa,+alsa-lib @FS_WITH_ALSA))
 $(eval $(call BuildPlugin,portaudio-stream,Portaudio Streaming Interface,vanilla,,,alsa,+alsa-lib @FS_WITH_ALSA))
 $(eval $(call BuildPlugin,posix-timer,POSIX Compliant Soft Timer,vanilla,,,,))
@@ -1066,7 +1080,7 @@ $(eval $(call BuildPlugin,snmp,SNMP AgentX Subagent,vanilla,,,,+libnetsnmp))
 $(eval $(call BuildPlugin,snom,SNOM specific features,vanilla,,,,))
 $(eval $(call BuildPlugin,sofia,SOFIA SIP,mod,,,,)) # ~/conf
 $(eval $(call BuildPlugin,sonar,Sonar Ping Timer,vanilla,,,,))
-$(eval $(call BuildPlugin,spandsp,Span DSP,mod,,,,+libjpeg)) # ~/conf
+$(eval $(call BuildPlugin,spandsp,Span DSP,mod,,,,+libjpeg +FS_WITH_LZMA:liblzma)) # ~/conf
 $(eval $(call BuildPlugin,speex,Speex codec,mod,,,,))
 $(eval $(call BuildPlugin,spidermonkey,JavaScript,vanilla,,,,@BROKEN)) # fails in js
 $(eval $(call BuildPlugin,spidermonkey-core_db,JavaScript DB,vanilla,,,,@BROKEN))