git update
[packages.git] / net / freeswitch / Makefile
index 64de197..78d9eb7 100644 (file)
@@ -9,6 +9,7 @@ include $(TOPDIR)/rules.mk
 
 
 PKG_NAME:=freeswitch
+PKG_DISTNAME:=$(PKG_NAME)_git
 PKG_VERSION:=1.0.7
 PKG_RELEASE:=1
 
@@ -16,12 +17,12 @@ PKG_RELEASE:=1
 #
 # The latest FS git hash in PKG_REV can be obtained from http://fisheye.freeswitch.org
 #
-PKG_REV:=f697e5aa37e0aae56ce7d07ce74080fe809ddf25
+PKG_REV:=50328a663452006b78e79e2004c20d111ffb263f
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_SOURCE_SUBDIR)_git-$(shell echo $(PKG_REV)|cut -b -9).tar.bz2
+PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR)-$(shell echo $(PKG_REV)|cut -b -9).tar.bz2
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 
@@ -34,6 +35,7 @@ FS_MOD_AVAILABLE:= \
        amr \
        amrwb \
        avmd \
+       blacklist \
        bv \
        callcenter \
        cdr-csv \
@@ -76,6 +78,7 @@ FS_MOD_AVAILABLE:= \
        h26x \
        h323 \
        hash \
+       http_cache \
        ilbc \
        java \
        json-cdr \
@@ -111,10 +114,11 @@ FS_MOD_AVAILABLE:= \
        siren \
        skinny \
        skypopen \
+       sms \
        snapshot \
-       snmp \
        snipe-hunt \
        sndfile \
+       snmp \
        snom \
        sofia \
        spandsp \
@@ -141,13 +145,12 @@ FS_MOD_AVAILABLE:= \
 
 
 PKG_CONFIG_DEPENDS:= \
-       CONFIG_FS_SOFIA_WITH_GNUTLS \
        CONFIG_FS_SOFIA_WITH_IPV6 \
+       CONFIG_FS_SOFIA_WITH_MYSQL \
        CONFIG_FS_SOFIA_WITH_ODBC \
        CONFIG_FS_SOFIA_WITH_OPT \
        CONFIG_FS_SOFIA_WITH_SCTP \
        CONFIG_FS_SOFIA_WITH_ZRTP_GIT \
-       CONFIG_FS_SOFIA_WITHOUT_MYSQL \
        $(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-mod-%,$(FS_MOD_AVAILABLE)) \
 
 
@@ -155,6 +158,9 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
 
+TAR_OPTIONS+= --strip-components=1 -C $(PKG_BUILD_DIR)
+
+
 define Package/$(PKG_NAME)/Default
   SECTION:=net
   CATEGORY:=Network
@@ -193,51 +199,43 @@ define Package/$(PKG_NAME)/config
     default y
     help
             Compile $(PKG_NAME) with optimization enabled.
-
-    config FS_SOFIA_WITHOUT_MYSQL
-    depends on PACKAGE_$(PKG_NAME)
-    bool "Compile without MySQL"
-    default y
-    help
-            Compile $(PKG_NAME) without MySQL.
 endef
 
 
-define Package/$(PKG_NAME)-mod-dingaling/config
-    config FS_SOFIA_WITH_GNUTLS
-    depends on PACKAGE_$(PKG_NAME)-mod-dingaling
-    bool "Compile with GNU TLS (Requires libgnutls-openssl)"
-    default y
-    select PACKAGE_libgnutls-openssl
+define Package/$(PKG_NAME)-mod-sofia/config
+    config FS_SOFIA_WITH_MYSQL
+    depends on PACKAGE_$(PKG_NAME)-mod-sofia
+    bool "Compile with MySQL"
+    default n
+    select PACKAGE_libmysqlclient
     help
-            Compile $(PKG_NAME)-mod-dingaling with GNU TLS Support (Requires libgnutls-openssl package).
-endef
+            Compile $(PKG_NAME) with MySQL.
 
-
-define Package/$(PKG_NAME)-mod-sofia/config
     config FS_SOFIA_WITH_ODBC
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
-    bool "Compile with ODBC support (BROKEN: Requires unixodbc_svn)"
+    depends on PACKAGE_sqliteodbc
+    depends on PACKAGE_unixodbc_svn
+    bool "Compile with ODBC support (Requires unixodbc_svn NOT YET AVAILABLE)"
     default n
-    select PACKAGE_unixodbc_svn
     help
-            Compile $(PKG_NAME)-mod-sofia with ODBC Support (Requires unixodbc_svn package).
+            Compile $(PKG_NAME)-mod-sofia with ODBC Support. Since both sqliteodbc and unixodbc_svn packages are not yet available on OpenWRT, $(PKG_NAME)-mod-sofia CAN NOT be compiled with ODBC support.
 
     config FS_SOFIA_WITH_SCTP
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
-    bool "Compile with SCTP support (BROKEN)"
-    default n
-    select PACKAGE_sctp
+    depends on PACKAGE_sctp
+    bool "Compile with SCTP (Stream Control Transfer Protocol) support"
+    default y
     help
-            Compile $(PKG_NAME)-mod-sofia with SCTP (Stream Control Transfer Protocol) support.
+            Compile $(PKG_NAME)-mod-sofia with SCTP support.
 
     config FS_SOFIA_WITH_ZRTP_GIT
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
-    bool "Compile with ZRTP support (BROKEN: Requires libzrtpcpp)"
+    depends on PACKAGE_libzrtpcpp
+    bool "Compile with ZRTP support (Requires libzrtpcpp NOT YET AVAILABLE)"
     default n
-    select PACKAGE_libzrtpcpp
+    #select PACKAGE_libzrtpcpp
     help
-            Compile $(PKG_NAME)-mod-sofia with ZRTP Support (Requires libzrtpcpp package).
+            Compile $(PKG_NAME)-mod-sofia with ZRTP Support. Since libzrtpcpp package is not yet available on OpenWRT, $(PKG_NAME)-mod-sofia CAN NOT be compiled with ZRTP support.
 endef
 
 
@@ -299,6 +297,7 @@ $(call Package/$(PKG_NAME)/Default)
                +$(PKG_NAME)-mod-g723-1 \
                +$(PKG_NAME)-mod-g729 \
                +$(PKG_NAME)-mod-hash \
+               +$(PKG_NAME)-mod-http-cache \
                +$(PKG_NAME)-mod-ilbc \
                +$(PKG_NAME)-mod-local-stream \
                +$(PKG_NAME)-mod-lua \
@@ -384,12 +383,12 @@ endif
 
 
 ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-event-zmq),)
- $(eval $(call Download/files,event-zmq,zeromq-2.1.7.tar.gz,7d3120f8a8fb913a7e55c57c6eb024f3,http://download.zeromq.org,,libs/))
+ $(eval $(call Download/files,event-zmq,zeromq-2.1.9.tar.gz,94c5e0262a79c5f82bc0b178c1f8a33d,http://download.zeromq.org,,libs/))
 endif
 
 
 ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-flite),)
- $(eval $(call Download/files,flite,flite-1.3.99-latest.tar.gz,365b60881715c5e13c0d8bc37d9be6ff,,downloads/libs/,libs/))
+ $(eval $(call Download/files,flite,flite-1.5.1-current.tar.bz2,36e5d1c1307161211c8ffe9a75a623ae,,downloads/libs/,libs/))
 endif
 
 
@@ -441,18 +440,17 @@ CONFIGURE_ARGS+= \
        --sysconfdir="/etc/$(PKG_NAME)" \
        --with-modinstdir="/usr/lib/$(PKG_NAME)" \
        --with-random="/dev/urandom" \
-       $(if $(CONFIG_FS_SOFIA_WITHOUT_MYSQL),--without-mysql) \
+       $(if $(CONFIG_FS_SOFIA_WITH_MYSQL),--with-mysql,--without-mysql) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_IPV6,ipv6) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_OPT,optimization) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-celt),--with-ogg="$(STAGING_DIR)/usr",--without-iogg) \
        $(if ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-curl)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-cdr)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-curl)),--with-libcurl="$(STAGING_DIR)/usr",--without-libcurl) \
-       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-dingaling)|$(CONFIG_FS_SOFIA_WITH_GNUTLS),--with-libgnutls="$(STAGING_DIR)/usr") \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-java),--with-java="$(STAGING_DIR)/usr",--without-java) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp,builtin-tiff) \
-       $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_SCTP,sctp) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_ZRTP_GIT,zrtp) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_ODBC,core-odbc-support) \
        $(if $(CONFIG_FS_SOFIA_WITH_ODBC),--with-odbc="$(STAGING_DIR)/usr") \
+       $(if $(CONFIG_FS_SOFIA_WITH_ODBC),--with-odbc-lib="$(STAGING_DIR)/usr/lib") \
 
 
 CONFIGURE_VARS+= \
@@ -492,13 +490,11 @@ CONFIGURE_VARS+= \
        apr_cv_process_shared_works="no" \
        apr_cv_tcp_nodelay_with_cork="yes" \
        apr_cv_type_rwlock_t="yes" \
-       ac_cv_path_LIBGNUTLS_CONFIG="no" \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-perl),ac_cv_path_PERL="yes",) \
        libzmq_cv_cxx_werror_flag="" \
 
 
 define Build/Prepare
-       (cd $(PKG_BUILD_DIR); [ -h noreg ] || touch noreg)
        $(call Build/Prepare/Default)
        $(call Prepare/celt)
        $(call Prepare/event-zmq)
@@ -531,7 +527,7 @@ define Build/Compile
                CXX="$(TARGET_CXX)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
-               spandsp-reconf all $(MAKE_INSTALL_TARGETS)
+               all $(MAKE_INSTALL_TARGETS)
        $(SED) 's|^\([ \t]*\)\(.*\)"mod_console"\(.*\)$$$$|\1<!-- \2"mod_console"\3 -->|' $(PKG_INSTALL_DIR)/etc/$(PKG_NAME)/autoload_configs/modules.conf.xml
        $(SED) 's|^\([ \t]*\)<!-- *\(.*\)"mod_syslog"\(.*\) *-->\(.*\)$$$$|\1\2"mod_syslog"\3\4|' $(PKG_INSTALL_DIR)/etc/$(PKG_NAME)/autoload_configs/modules.conf.xml
 endef
@@ -569,7 +565,6 @@ endef
 
 define Package/$(PKG_NAME)-example-config/install
        $(INSTALL_DIR) $(1)/usr/share/$(PKG_NAME)/examples/conf
-       #$(INSTALL_DIR) $(1)/var/log/$(PKG_NAME)/xml_cdr
        $(CP) $(PKG_INSTALL_DIR)/etc/$(PKG_NAME)/* $(1)/usr/share/$(PKG_NAME)/examples/conf/
 endef
 
@@ -681,9 +676,10 @@ $(eval $(call BuildPlugin,amr,GSM-AMR codec,mod_amr,,))
 $(eval $(call BuildPlugin,amrwb,GSM-AMRWB,mod_amrwb,,))
 $(eval $(call BuildPlugin,avmd,Advanced Voice Mail Detection,mod_avmd,,))
 $(eval $(call BuildPlugin,bv,codec mod_bv,mod_bv,,))
+$(eval $(call BuildPlugin,blacklist,application blacklist,mod_blacklist,,))
 $(eval $(call BuildPlugin,callcenter,Call Center,mod_callcenter,,))
 $(eval $(call BuildPlugin,cdr-csv,CSV-CDR handler,mod_cdr_csv,,))
-$(eval $(call BuildPlugin,cdr-pg-csv,Postgress CDR handler,mod_cdr_pg_csv,,+libpq))
+$(eval $(call BuildPlugin,cdr-pg-csv,Postgress CDR handler,mod_cdr_pg_csv,,+coreutils +libpq))
 $(eval $(call BuildPlugin,cdr-sqlite,SQLite3 CDR handler,mod_cdr_sqlite,,+sqlite3))
 $(eval $(call BuildPlugin,celt,CELT ultra-low delay codec,mod_celt,,+libogg))
 $(eval $(call BuildPlugin,cepstral,Cepstral interface,mod_cepstral,,@BROKEN)) # needs <swift.h>
@@ -722,6 +718,7 @@ $(eval $(call BuildPlugin,gsmopen,Short Message Service (SMS),mod_gsmopen,spands
 $(eval $(call BuildPlugin,h26x,H26X linear codec,mod_h26x,,))
 $(eval $(call BuildPlugin,h323,h323 endpoint,mod_h323,,@BROKEN)) # missing header files (other packages needed)
 $(eval $(call BuildPlugin,hash,API for manipulating a hash table,mod_hash,,))
+$(eval $(call BuildPlugin,http_cache,HTTP GET with caching,mod_http_cache,,))
 $(eval $(call BuildPlugin,ilbc,ILBC codec,mod_ilbc,,))
 $(eval $(call BuildPlugin,java,Java language interface,mod_java,,@BROKEN)) # needs java
 $(eval $(call BuildPlugin,json-cdr,JSon-CDR interface,mod_json_cdr,,))
@@ -756,7 +753,8 @@ $(eval $(call BuildPlugin,shell-stream,Shell stream,mod_shell_stream,,))
 $(eval $(call BuildPlugin,silk,codec mod_silk,mod_silk,,))
 $(eval $(call BuildPlugin,siren,G.722.1 codec,mod_siren,,))
 $(eval $(call BuildPlugin,skinny,endpoint mod_skinny,mod_skinny,,))
-$(eval $(call BuildPlugin,skypopen,Skype compatible endpoint,mod_skypopen,,+libX11))
+$(eval $(call BuildPlugin,skypopen,Skype compatible endpoint,mod_skypopen,,@FEATURE_drawing-backend_libX11))
+$(eval $(call BuildPlugin,sms,SMS application,mod_sms,,))
 $(eval $(call BuildPlugin,snapshot,application mod_snapshot,mod_snapshot,,))
 $(eval $(call BuildPlugin,sndfile,Multi-Format file transcoder,mod_sndfile,,))
 $(eval $(call BuildPlugin,snipe-hunt,application mod_snipe_hunt,mod_snipe_hunt,,))