radsecproxy: moved to github
[packages.git] / net / djbdns / Makefile
index 2dae095..04d60b2 100644 (file)
@@ -1,4 +1,5 @@
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2012 OpenWrt.org
 # Original port by FreeWRT project.
 #
 # 2007     Alexander Tsvyashchenko  Adapted FreeWRT port for OpenWRT (Trac ticket 2497)
@@ -13,7 +14,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=djbdns
 PKG_VERSION:=1.05
-PKG_RELEASE:=5
+PKG_RELEASE:=7
 
 PKG_SOURCE:=${PKG_NAME}-${PKG_VERSION}.tar.gz
 PKG_SOURCE_URL:=http://cr.yp.to/djbdns/
@@ -72,13 +73,13 @@ endef
 
 define Package/djdbns/description
        djbdns is a collection of Domain Name System tools.
-               It includes software for all the fundamental DNS operations: 
+       It includes software for all the fundamental DNS operations:
        * DNS server: publishing addresses of Internet hosts.
        * DNS cache: finding addresses of Internet hosts.
        * DNS client: talking to a DNS cache.
-               
+
        Also included is a DNS client C library, several command-line
-               DNS client utilities, several DNS debugging tools.
+       DNS client utilities, several DNS debugging tools.
 endef
 
 define Package/djbdns-base/description
@@ -87,36 +88,36 @@ endef
 
 define Package/djbdns-dnscache/description
        dnscache is a DNS cache.
-               It accepts recursive DNS queries from local clients such as web
-               browsers and mail transfer agents. It collects responses from
-       remote DNS servers. It caches the responses to save time later. 
+       It accepts recursive DNS queries from local clients such as web
+       browsers and mail transfer agents. It collects responses from
+       remote DNS servers. It caches the responses to save time later.
 endef
 
 define Package/djbdns-tinydns/description
        tinydns is a DNS server.
        It accepts iterative DNS queries from hosts around the Internet
-               and responds with locally configured information. 
+       and responds with locally configured information.
 endef
 
 define Package/djbdns-axfrdns/description
        axfrdns is a DNS zone-transfer server.
        It reads a zone-transfer request in DNS-over-TCP format
-               from its standard input and responds with locally configured
-       information. 
+       from its standard input and responds with locally configured
+       information.
 endef
 
 define Package/djbdns-rbldns/description
        rbldns is an IP-address-listing DNS server.
        It accepts iterative DNS queries from hosts around the Internet asking
-               about various IP addresses. It provides responses showing whether the
-       addresses are on a locally configured list, such as RBL or DUL. 
+       about various IP addresses. It provides responses showing whether the
+       addresses are on a locally configured list, such as RBL or DUL.
 endef
 
 define Package/djbdns-walldns/description
        walldns is a reverse DNS wall.
        It accepts iterative DNS queries for in-addr.arpa domains from hosts
-               around the Internet and supplies generic responses that avoid
-       revealing local host information. 
+       around the Internet and supplies generic responses that avoid
+       revealing local host information.
 endef
 
 define Package/djbdns-tools/description
@@ -136,6 +137,10 @@ define Package/djbdns-base/install
        $(INSTALL_DATA) ./files/djbdns.conf $(1)/etc/config/djbdns
 endef
 
+define Package/djbdns-base/conffiles
+/etc/config/djbdns
+endef
+
 define Package/djbdns-dnscache/install
        $(INSTALL_DIR) $(1)/usr/bin
        (cd $(PKG_BUILD_DIR); \
@@ -201,4 +206,3 @@ $(eval $(call BuildPackage,djbdns-axfrdns))
 $(eval $(call BuildPackage,djbdns-rbldns))
 $(eval $(call BuildPackage,djbdns-walldns))
 $(eval $(call BuildPackage,djbdns-tools))
-