[packages] utils/collectd: Added missing dependency to iptables
[packages.git] / net / autossh / Makefile
index af20c76..55055a3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,24 +9,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autossh
-PKG_VERSION:=1.4a
+PKG_VERSION:=1.4b
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
-PKG_MD5SUM:=a5497938986f0c179926f1ebba603767
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=8f9aa006f6f69e912d3c2f504622d6f7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/autossh
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+openssh-client
   TITLE:=Autossh client
   URL:=http://www.harding.motd.ca/autossh/
+  SUBMENU:=SSH
 endef
 
 define Build/Compile
@@ -39,6 +36,10 @@ endef
 define Package/autossh/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/autossh $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/autossh.init $(1)/etc/init.d/autossh
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/autossh.config $(1)/etc/config/autossh
 endef
 
 $(eval $(call BuildPackage,autossh))