asterisk-1.8.x: fix up asterisk dependency for lantiq modules
[feed/telephony.git] / net / asterisk-1.8.x / Makefile
index 66eb42d..329d805 100644 (file)
@@ -8,16 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk18
-PKG_VERSION:=1.8.29.0
-PKG_RELEASE:=5
+PKG_VERSION:=1.8.32.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/asterisk/releases/
-PKG_MD5SUM:=23778d7ebefdecd4c742d5de39f5e2c1
+PKG_MD5SUM:=3616c4fe038f242d2f9fce66dc571aa0
 
 PKG_BUILD_DIR=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
 
-include $(INCLUDE_DIR)/ltqtapi.mk
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING LICENSE
+PKG_MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk18/install/module
@@ -76,7 +79,6 @@ define Package/asterisk18/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.asterisk.org/
-  MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 endef
 
 define Package/asterisk18/Default/description
@@ -130,27 +132,6 @@ $(foreach m,$(AST_EMB_MODULES),$(call Package/asterisk18/install/module,$(1),$(m
        $(INSTALL_BIN) ./files/asterisk.init $(1)/etc/init.d/asterisk
 endef
 
-define Package/asterisk18-chan-lantiq
-$(call Package/asterisk18/Default)
-  TITLE:=Lantiq TAPI support
-  DEPENDS:= asterisk18 $(LTQ_TAPI_DEPENDS)
-  URL:=http://git.nanl.de/?p=asterisk_channel_lantiq.git
-endef
-
-define Package/asterisk18-chan-lantiq/description
-$(call Package/asterisk18/Default/description)
- This package provides the channel chan_lantiq support to Asterisk.
-endef
-
-define Package/asterisk18-chan-lantiq/conffiles
-/etc/asterisk/lantiq.conf
-endef
-
-define Package/asterisk18-chan-lantiq/install
-$(call Package/asterisk18/install/conffile,lantiq.conf,$(m))
-$(call Package/asterisk18/install/module,chan_lantiq,$(m))
-endef
-
 define Package/asterisk18-sounds
 $(call Package/asterisk18/Default)
   TITLE:=Sounds support
@@ -214,10 +195,10 @@ endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-res-fax-spandsp),)
   CONFIGURE_ARGS+= \
-    --with-spandsp="$(STAGING_DIR)/usr"
+       --with-spandsp="$(STAGING_DIR)/usr"
 else
   CONFIGURE_ARGS+= \
-    --without-spandsp
+       --without-spandsp
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-res-srtp),)
@@ -296,7 +277,6 @@ define Build/InstallDev
 endef
 
 $(eval $(call BuildPackage,asterisk18))
-$(eval $(call BuildPackage,asterisk18-chan-lantiq))
 $(eval $(call BuildPackage,asterisk18-sounds))
 
 ################################
@@ -363,11 +343,12 @@ $(eval $(call BuildAsterisk18Module,func-vmcount,vmcount dialplan,a vmcount dial
 $(eval $(call BuildAsterisk18Module,chan-agent,Agents proxy channel,An implementation of agents proxy channel,,,,chan_agent,))
 $(eval $(call BuildAsterisk18Module,chan-gtalk,GTalk,An implementation of chan_gtalk and res_jabber for GTalk support,+libiksemel,/etc/asterisk/gtalk.conf /etc/asterisk/jabber.conf,gtalk.conf jabber.conf,chan_gtalk res_jabber,))
 $(eval $(call BuildAsterisk18Module,chan-iax2,IAX2 channel,An implementation of IAX2 channel,+asterisk18-res-timing-timerfd,/etc/asterisk/iax.conf /etc/asterisk/iaxprov.conf,iax.conf iaxprov.conf,chan_iax2,))
+$(eval $(call BuildAsterisk18Module,chan-lantiq,Lantiq TAPI channel,An implementation of Lantiq TAPI channel,@TARGET_lantiq +kmod-ltq-vmmc,/etc/asterisk/lantiq.conf,lantiq.conf,chan_lantiq,))
 $(eval $(call BuildAsterisk18Module,chan-local,Local proxy channel,An implementation of local proxy channel,,,,chan_local,))
 $(eval $(call BuildAsterisk18Module,chan-mgcp,MGCP channel,the channel chan_mgcp,,/etc/asterisk/mgcp.conf,mgcp.conf,chan_mgcp,))
 $(eval $(call BuildAsterisk18Module,chan-ooh323,ooH323 channel,the channel chan_ooh323,,/etc/asterisk/ooh323.conf,ooh323.conf,chan_ooh323,))
 $(eval $(call BuildAsterisk18Module,chan-skinny,Skinny channel,the channel chan_skinny,,/etc/asterisk/skinny.conf,skinny.conf,chan_skinny,))
-$(eval $(call BuildAsterisk18Module,mysql,MySQL,MySQL support,+libmysqlclient @BROKEN,/etc/asterisk/res_config_mysql.conf,res_config_mysql.conf,res_config_mysql,))
+$(eval $(call BuildAsterisk18Module,mysql,MySQL,MySQL support,+libmysqlclient,/etc/asterisk/res_config_mysql.conf,res_config_mysql.conf,res_config_mysql,))
 $(eval $(call BuildAsterisk18Module,odbc,ODBC,ODBC support,+libpthread +libc +unixodbc,/etc/asterisk/cdr_adaptive_odbc.conf /etc/asterisk/cdr_odbc.conf /etc/asterisk/cel_odbc.conf /etc/asterisk/func_odbc.conf /etc/asterisk/res_odbc.conf,cdr_adaptive_odbc cdr_odbc cel_odbc func_odbc res_odbc,cdr_adaptive_odbc cdr_odbc cel_odbc func_odbc res_config_odbc res_odbc,))
 $(eval $(call BuildAsterisk18Module,pgsql,PostgreSQL,PostgreSQL support,+libpq,/etc/asterisk/cel_pgsql.conf /etc/asterisk/cdr_pgsql.conf /etc/asterisk/res_pgsql.conf,cel_pgsql.conf cdr_pgsql.conf res_pgsql.conf,cel_pgsql cdr_pgsql res_config_pgsql,))
 $(eval $(call BuildAsterisk18Module,pbx-ael,Asterisk Extension Logic,support for symbolic Asterisk Extension Logic,,,extensions.ael,pbx_ael,))