asterisk: remove dependency to bluetooth, remove chan-mobile subpackage
[feed/telephony.git] / net / asterisk-1.8.x / Makefile
index 5779ffa..d987f22 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk18
 PKG_VERSION:=1.8.29.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/asterisk/releases/
@@ -179,14 +179,6 @@ else
        --without-iksemel
 endif
 
-ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-chan-mobile),)
-  CONFIGURE_ARGS+= \
-       --with-bluetooth="$(STAGING_DIR)/usr"
-else
-  CONFIGURE_ARGS+= \
-       --without-bluetooth
-endif
-
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-curl),)
   CONFIGURE_ARGS+= \
        --with-libcurl="$(STAGING_DIR)/usr"
@@ -241,6 +233,7 @@ EXTRA_LDFLAGS+= $(TARGET_LDFLAGS)
 CONFIGURE_ARGS+= \
        --without-curses \
        --with-gsm=internal \
+       --without-bluetooth \
        --without-cap \
        --without-dahdi \
        --without-gtk2 \
@@ -372,7 +365,6 @@ $(eval $(call BuildAsterisk18Module,chan-gtalk,GTalk,An implementation of chan_g
 $(eval $(call BuildAsterisk18Module,chan-iax2,IAX2 channel,An implementation of IAX2 channel,+asterisk18-res-timing-timerfd,/etc/asterisk/iax.conf /etc/asterisk/iaxprov.conf,iax.conf iaxprov.conf,chan_iax2,))
 $(eval $(call BuildAsterisk18Module,chan-local,Local proxy channel,An implementation of local proxy channel,,,,chan_local,))
 $(eval $(call BuildAsterisk18Module,chan-mgcp,MGCP channel,the channel chan_mgcp,,/etc/asterisk/mgcp.conf,mgcp.conf,chan_mgcp,))
-$(eval $(call BuildAsterisk18Module,chan-mobile,Mobile channel,the channel chan_mobile,+bluez-libs,/etc/asterisk/chan_mobile.conf,chan_mobile.conf,chan_mobile,))
 $(eval $(call BuildAsterisk18Module,chan-ooh323,ooH323 channel,the channel chan_ooh323,,/etc/asterisk/ooh323.conf,ooh323.conf,chan_ooh323,))
 $(eval $(call BuildAsterisk18Module,chan-skinny,Skinny channel,the channel chan_skinny,,/etc/asterisk/skinny.conf,skinny.conf,chan_skinny,))
 $(eval $(call BuildAsterisk18Module,mysql,MySQL,MySQL support,+libmysqlclient,/etc/asterisk/res_config_mysql.conf,res_config_mysql.conf,res_config_mysql,))