[packages] gstreamer: Enable debugging and add gst_log2_debug symbol
[packages.git] / net / appweb / Makefile
index 2437761..6c81e52 100644 (file)
@@ -16,10 +16,10 @@ PKG_RELEASE:=1
 #
 #      Build stable
 #
-PKG_VERSION:=3.2.2-1
-PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
+PKG_VERSION:=3.4.1-0
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tgz
 PKG_SOURCE_URL:=http://www.appwebserver.org/software/
-PKG_MD5SUM:=060d43c8194fa6a119cada966fc807a7
+PKG_MD5SUM:=23540af5852e4b0f6789bc47013d311c
 
 #
 #      Build the latest snapshot from the default trunk
@@ -31,13 +31,35 @@ PKG_MD5SUM:=060d43c8194fa6a119cada966fc807a7
 
 include $(INCLUDE_DIR)/package.mk
 
+# The files in the .tar.gz are
+#    src/all/...
+#    src/build/...
+#    src/test/...
+# and so on
+#
+# What we want is
+#    $(PKG_BUILD_DIR)/all/...
+#    $(PKG_BUILD_DIR)/build/...
+#    $(PKG_BUILD_DIR)/test/...
+# and so on
+#
+# The following two lines make this happen
+#    1.  change tar option to strip out the top-level, src in
+#        this case
+#    2.  change the tar output to the build directory.  The
+#        original tar command was
+#        $(HOST_TAR) -C/.. $(1) $(TAR_OPTIONS)
+
+TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
+TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
+
 define Package/appweb
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Web Servers/Proxies
   TITLE:=Appweb Web Server
   URL:=http://www.appwebserver.org/
-  DEPENDS:=@!avr32 +libpthread
+  DEPENDS:=@!avr32 +libpthread +libpcre +libsqlite3
 endef
 
 define Package/appweb/description
@@ -63,10 +85,6 @@ CONFIGURE_ARGS += \
        --sslPort=8443 \
        --config=flat
 
-define Build/Prepare
-       tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"
-endef
-
 define Build/Configure
        $(call Build/Configure/Default)
 endef