pyload: update to current version 0.4.9
[packages.git] / net / apache / Makefile
index 8ce9310..b1a1106 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apache
-PKG_VERSION:=2.2.14
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.15
+PKG_RELEASE:=3
 PKG_SOURCE_NAME:=httpd
 
 PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
                http://apache.imsam.info/httpd/
-PKG_MD5SUM:=a5226203aaf97e5b941c41a71c112704
+PKG_MD5SUM:=016cec97337eccead2aad6a7c27f2e14
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
 
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/apache/Default
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   TITLE:=The Apache Web Server
   URL:=http://httpd.apache.org/
 endef
@@ -39,7 +39,7 @@ endef
 
 define Package/apache
 $(call Package/apache/Default)
-  DEPENDS:=+libapr +libaprutil +libpcre +libopenssl
+  DEPENDS:=+libapr +libaprutil +libpcre +libopenssl +unixodbc
 endef
 
 define Package/apache/description
@@ -87,6 +87,9 @@ $(call Package/apache/Default/description)
  This package contains the icons from Apache.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
@@ -102,6 +105,7 @@ define Build/Configure
                --sysconfdir=/etc/apache \
                ap_cv_void_ptr_lt_long=no \
                logfiledir="/var/log" \
+               runtimedir="/var/run" \
        )
 endef