fix various compile issues
[packages.git] / net / aircrack-ng / Makefile
index 8fcc0e2..53328a1 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aircrack-ng
-PKG_VERSION:=0.6
+PKG_VERSION:=0.6.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=6b85fe925c93c972f3d9f8170dce46c6
+PKG_MD5SUM:=8a72ad4746752dac9127edb3b41f6274
 
-PKG_SOURCE_URL:=http://download.aircrack-ng.org
+PKG_SOURCE_URL:=http://download.aircrack-ng.org/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
@@ -25,6 +25,7 @@ define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Aircrack-ng the next generation of aircrack with new features
+  DEPENDS:=+libpthread
   DESCRIPTION:=Aircrack-ng the next generation of aircrack with new features
   URL:=http://www.aircrack-ng.org
 endef
@@ -36,7 +37,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
+               $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -Wall" \
                prefix="/usr" \
                destdir="$(PKG_INSTALL_DIR)" \