[packages] gst-plugins-base, gst-plugins-good, gst-plugins-ugly: use nls.mk
[packages.git] / multimedia / gst-plugins-base / Makefile
index 1d469ed..d867fd3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst-plugins-base
-PKG_VERSION:=0.10.25
+PKG_VERSION:=0.10.29
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
-PKG_MD5SUM:=d29669dd79276c5cd94e1613c03cd9ab
-PKG_FIXUP:=libtool
-
-include $(INCLUDE_DIR)/package.mk
+PKG_MD5SUM:=d07e251152cccbaa81807c14cf0fd8c0
 
-export PATH:=$(PKG_BUILD_DIR)/bin:$(TARGET_PATH)
+PKG_BUILD_DEPENDS:= gstreamer liboil
 
-PKG_INSTALL=1
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
-EXTRA_CFLAGS+= \
-       -I$(STAGING_DIR)/usr/lib/libintl/include \
-       -I$(STAGING_DIR)/usr/lib/libiconv/include \
-       -I$(STAGING_DIR)/usr/include/gtk-2.0/gdk \
-       -I$(STAGING_DIR)/usr/include/gstreamer-0.10
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
-EXTRA_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       -L$(STAGING_DIR)/usr/lib/libintl/lib \
-       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+# -liconv crept in from pkg-config, to be revisited later
+include $(INCLUDE_DIR)/nls.mk
 
-define Package/gst-plugins-base/Default
-  SECTION:=multimedia
+define Package/gstreamer/Default
   CATEGORY:=Multimedia
-  DEPENDS:=+gstreamer +liboil +gst-plugins-base-libs
-  TITLE:=gst-plugins-base
+  SECTION:=multimedia
+  TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
+  DEPENDS:= @!LINUX_2_4
 endef
 
-define Package/gst-plugins-base-libs
-  $(call Package/gst-plugins-base/Default)
-  DEPENDS:=+gstreamer +liboil
-  TITLE:=gstreamber plugins base libraries
+define Package/gstreamer/description/Default
+ GStreamer open source multimedia framework
 endef
 
-define Package/gst-plugins-base-ogg
-  $(call Package/gst-plugins-base/Default)
-  TITLE += (ogg)
-  DEPENDS += +libogg
-endef
 
-define Package/gst-plugins-base-ogg/description
-  gstreamer OGG plugins
+define Package/gst-plugins-base
+$(call Package/gstreamer/Default)
+  TITLE+= plugins collection (base)
+  DEPENDS+= $(GST_DEPENDS)
 endef
 
-define Package/gst-plugins-base-vorbis
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (vorbis)
-  DEPENDS:=+gst-plugins-base-ogg +libvorbis
+define Package/gts-plugins-base/description
+$(call Package/gstreamer/description/Default)
+ .
+ This meta package contains only dependencies to the other libraries and
+ plugins from the base plugins collection.
 endef
 
-define Package/gst-plugins-base-vorbis/description
-  gstreamer Vorbis plugins
-endef
 
-define Package/gst-plugins-base-theora
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (theora)
-  DEPENDS:=+gst-plugins-base-ogg +libtheora
-endef
+GST_VERSION:=0.10
 
-define Package/gst-plugins-base-theora/description
-  gstreamer Theora plugins
-endef
-
-define Package/gst-plugins-base-alsa
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (alsa)
-endef
+CONFIGURE_ARGS += \
+       --disable-debug \
+       --disable-examples \
+       \
+       --disable-cdparanoia \
+       --disable-ffmpegcolorspace \
+       --disable-freetypetest \
+       --disable-gnome_vfs \
+       --disable-gst_v4l \
+       --disable-libvisual \
+       --disable-oggtest \
+       --disable-pango \
+       --disable-subparse \
+       --disable-videorate \
+       --disable-videoscale \
+       --disable-vorbistest \
+       --disable-x \
+       --disable-xshm \
+       --disable-xvideo \
+       \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+       --without-x \
+       \
+       --with-audioresample-format=int \
 
-define Package/gst-plugins-base-alsa/description
-  gstreamer ALSA plugins
-endef
-
-define Package/gst-plugins-base-app
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (app)
-endef
+EXTRA_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
 
-define Package/gst-plugins-base-app/description
-  gstreamer app plugins
-endef
 
-define Package/gst-plugins-base-audioconvert
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (audioconvert)
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/include/gstreamer-$(GST_VERSION)/* \
+               $(1)/usr/include/gstreamer-$(GST_VERSION)/ \
+       )
+       $(INSTALL_DIR) $(1)/usr/lib
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/libgst*-$(GST_VERSION).{a,la,so*} \
+               $(1)/usr/lib/ \
+       )
+       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/gstreamer-$(GST_VERSION)/libgst*.{la,so} \
+               $(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
+       )
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/pkgconfig/gstreamer*-$(GST_VERSION).pc \
+               $(1)/usr/lib/pkgconfig/ \
+       )
 endef
 
-define Package/gst-plugins-base-audioconvert/description
-  gstreamer audioconvert plugins
-endef
 
-define Package/gst-plugins-base-gio
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (gio)
-  DEPENDS += +glib2
+define Package/gst-plugins-base/install
+       /bin/true
 endef
 
-define Package/gst-plugins-base-gio/description
-  gstreamer GIO plugins
-endef
 
-define Package/gst-plugins-base-typefindfunctions
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (typefind)
-endef
+# 1: short name
+# 2: description
+# 3: dependencies on other gstreamer libraries (short name)
+# 4: dependencies on other packages
+define GstBuildLibrary
 
-define Package/gst-plugins-base-typefindfunctions/description
-  gstreamer typefind plugins
-endef
+  GST_DEPENDS += +libgst$(1)
 
-define Package/gst-plugins-base-decodebin
-  $(call Package/gst-plugins-base/Default)
-  TITLE+= (decodebin)
-endef
+  define Package/libgst$(1)
+    $(call Package/gstreamer/Default)
+    TITLE+= $(2) library (base)
+    DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $(4)
+  endef
 
-define Package/gst-plugins-base-decodebin/description
-  gstreamer decodebin plugins
-endef
+  define Package/libgst$(1)/description
+   $(call Package/gstreamer/description/Default)
+   .
+   This package contains the GStreamer $(2) library.
+  endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-pango \
-               --disable-gnome_vfs \
-               --disable-examples \
-               --disable-cdparanoia \
-               --disable-libvisual \
-               --disable-oggtest \
-               --disable-vorbistest \
-               --disable-freetypetest \
-               --without-x \
+  define Package/libgst$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/libgst$(1)-$(GST_VERSION).so.* \
+               $$(1)/usr/lib/ \
        )
-       mkdir -p $(PKG_BUILD_DIR)/bin
-       touch $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
-       chmod +x $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/gstreamer-0.10/gst/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/include/* \
-               $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} \
-               $(1)/usr/lib/
-
-       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.{so*,la} \
-               $(1)/usr/lib/gstreamer-0.10/
-
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
-               $(1)/usr/lib/pkgconfig/
-endef
+  endef
 
-define Package/gst-plugins-base-libs/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
-endef
+  $$(eval $$(call BuildPackage,libgst$(1)))
+endef
+
+$(eval $(call GstBuildLibrary,app,app,,))
+$(eval $(call GstBuildLibrary,audio,audio,interfaces,))
+$(eval $(call GstBuildLibrary,cdda,CDDA,,))
+$(eval $(call GstBuildLibrary,fft,FFT,,))
+$(eval $(call GstBuildLibrary,interfaces,interfaces,))
+$(eval $(call GstBuildLibrary,netbuffer,network buffer,,))
+$(eval $(call GstBuildLibrary,pbutils,utils,,))
+$(eval $(call GstBuildLibrary,riff,RIFF media,audio tag,,))
+$(eval $(call GstBuildLibrary,rtp,RTP,,))
+$(eval $(call GstBuildLibrary,rtsp,RTSP,,))
+$(eval $(call GstBuildLibrary,sdp,SDP,,))
+$(eval $(call GstBuildLibrary,tag,tag support,,))
+$(eval $(call GstBuildLibrary,video,video,,))
+
+
+# 1: short name
+# 2: description
+# 3: dependencies on other gstreamer libraries (short name)
+# 4: dependencies on other gstreamer plugins (short name)
+# 5: dependencies on other packages
+define GstBuildPlugin
+
+  GST_DEPENDS += +gst-mod-$(1)
+
+  define Package/gst-mod-$(1)
+    $(call Package/gstreamer/Default)
+    TITLE+= $(2) plugin (base)
+    DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $$(foreach p,$(4),+gst-mod-$$(p)) $(5)
+  endef
 
-define BuildPlugin
-  define Package/gst-plugins-base-$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/lib/gstreamer-0.10
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgst$(1).so \
-               $$(1)/usr/lib/gstreamer-0.10/
+  define Package/gst-mod-$(1)/description
+   $(call Package/gstreamer/description/Default)
+   .
+   This package contains the GStreamer $(2) plugin.
   endef
 
-  $$(eval $$(call BuildPackage,gst-plugins-base-$(1)))
-endef
+  define Package/gst-mod-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
+               $$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
+       )
+  endef
 
-$(eval $(call BuildPlugin,ogg))
-$(eval $(call BuildPlugin,vorbis))
-$(eval $(call BuildPlugin,theora))
-$(eval $(call BuildPlugin,alsa))
-$(eval $(call BuildPlugin,app))
-$(eval $(call BuildPlugin,audioconvert))
-$(eval $(call BuildPlugin,gio))
-$(eval $(call BuildPlugin,typefindfunctions))
-$(eval $(call BuildPlugin,decodebin))
-$(eval $(call BuildPackage,gst-plugins-base-libs))
+  $$(eval $$(call BuildPackage,gst-mod-$(1)))
+endef
+
+$(eval $(call GstBuildPlugin,alsa,ALSA,audio,,+alsa-lib))
+$(eval $(call GstBuildPlugin,app,app,app,,))
+$(eval $(call GstBuildPlugin,audioconvert,audio format conversion,audio,,))
+$(eval $(call GstBuildPlugin,audiorate,audio rate adjusting,,,))
+$(eval $(call GstBuildPlugin,audioresample,audio resampling,,,))
+$(eval $(call GstBuildPlugin,audiotestsrc,audio test,controller,,))
+$(eval $(call GstBuildPlugin,decodebin,media decoder,pbutils,,))
+$(eval $(call GstBuildPlugin,decodebin2,media decoder (v2),pbutils,,))
+$(eval $(call GstBuildPlugin,gio,GIO,,,))
+$(eval $(call GstBuildPlugin,ogg,Ogg,riff tag,,+libogg))
+$(eval $(call GstBuildPlugin,playbin,playback,interfaces pbutils,,))
+$(eval $(call GstBuildPlugin,tcp,TCP,dataprotocol,,))
+$(eval $(call GstBuildPlugin,theora,Theora,tag,ogg,+libtheora))
+$(eval $(call GstBuildPlugin,typefindfunctions,'typefind' functions,,,))
+$(eval $(call GstBuildPlugin,videotestsrc,video test,,,+liboil))
+$(eval $(call GstBuildPlugin,volume,volume,audio controller,,+liboil))
+$(eval $(call GstBuildPlugin,vorbis,Vorbis,audio tag,ogg,+libvorbis))
+
+$(eval $(call BuildPackage,gst-plugins-base))