[packages] fetchmail: update to 6.3.14
[packages.git] / mail / fetchmail / Makefile
index 3011679..c63f2d4 100644 (file)
@@ -1,20 +1,21 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fetchmail
-PKG_VERSION:=6.2.5
+PKG_VERSION:=6.3.14
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
-PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://download.berlios.de/fetchmail
+PKG_MD5SUM:=86d3cfbce151881d8bf76a1efd5bda6a
+
+PKG_INSTALL=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,7 +23,7 @@ define Package/fetchmail
   SECTION:=mail
   CATEGORY:=Mail
   TITLE:=Remote mail retriever
-  URL:=http://www.catb.org/~esr/fetchmail/
+  URL:=http://fetchmail.berlios.de/
 endef
 
 define Package/fetchmail/description
@@ -30,24 +31,16 @@ define Package/fetchmail/description
  Very useful in conjunction with mutt.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-fallback=procmail \
-               --without-hesiod \
-               , \
-               ac_cv_path_procmail=/usr/sbin/procmail \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-fallback=procmail \
+       --without-hesiod
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += \
+       ac_cv_path_procmail=/usr/sbin/procmail
 
 define Package/fetchmail/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fetchmail $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/fetchmail $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fetchmail))