[packages] libgdbm: update to 1.10
[packages.git] / libs / sqlite3 / Makefile
index 6afb869..2c41eeb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite
-PKG_VERSION:=3070701
+PKG_VERSION:=3071201
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-autoconf-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org
-PKG_MD5SUM:=554026fe7fac47b1cf61c18d5fe43419
+PKG_MD5SUM:=eb7bbd258913518ad30971ea7ecb0ca9
+
+PKG_LICENSE:=PUBLICDOMAIN
+PKG_LICENSE_FILES:=
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-autoconf-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libncurses libreadline
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 
 PKG_INSTALL:=1
 
@@ -64,7 +67,8 @@ $(call Package/sqlite3/Default/description)
  formats.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) \
+       -DSQLITE_ENABLE_UNLOCK_NOTIFY \
 
 CONFIGURE_ARGS += \
        --enable-shared \