bzip2: moved to github
[packages.git] / libs / sqlite2 / Makefile
index 44a90fd..5cc703e 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite2
 PKG_VERSION:=2.8.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=sqlite-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
@@ -19,9 +19,16 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/sqlite-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=libncurses libreadline
 
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/sqlite2/Default
+  SUBMENU:=database
   TITLE:=SQLite (v2.x) database engine
   URL:=http://www.sqlite.org/
 endef
@@ -34,9 +41,8 @@ define Package/libsqlite2
 endef
 
 define Package/libsqlite2/description
-=
-       SQLite is a small C library that implements a self-contained, embeddable, 
-       zero-configuration SQL database engine. 
+       SQLite is a small C library that implements a self-contained, embeddable,
+       zero-configuration SQL database engine.
        This package contains the SQLite (v2.x) shared library, used by other programs.
 endef
 
@@ -50,11 +56,10 @@ define Package/sqlite2-cli
 endef
 
 define Package/sqlite2-cli/description
-=
-       SQLite is a small C library that implements a self-contained, embeddable, 
-       zero-configuration SQL database engine. 
-       This package contains a terminal-based front-end to the SQLite (v2.x) library 
-       that can evaluate queries interactively and display the results in 
+       SQLite is a small C library that implements a self-contained, embeddable,
+       zero-configuration SQL database engine.
+       This package contains a terminal-based front-end to the SQLite (v2.x) library
+       that can evaluate queries interactively and display the results in
        multiple formats.
 endef
 
@@ -73,20 +78,12 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite.pc $(1)/usr/lib/pkgconfig/
 endef