[packages] liboil: don't build tools, docs and examples
[packages.git] / libs / libxslt / Makefile
index 7074ea3..13c0852 100644 (file)
@@ -1,27 +1,26 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxslt
-PKG_VERSION:=1.1.24
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.26
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=e83ec5d27fc4c10c6f612879bea9a153
+PKG_MD5SUM:=e61d0364a30146aaa3001296f853b2b9
+
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_INSTALL=1
-
 define Package/libxslt
   SECTION:=libs
   CATEGORY:=Libraries
@@ -34,10 +33,22 @@ define Package/libxslt/description
        A library for XML transformation using XSLT.
 endef
 
+define Package/libexslt
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libxslt
+  TITLE:=Gnome XSLT library Extention
+  URL:=http://xmlsoft.org/XSLT/EXSLT/
+endef
+
+define Package/libexslt/description
+       A extention for XSLT.
+endef
+
 define Package/xsltproc
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libxml2 +libxslt
+  DEPENDS:=+libxml2 +libxslt +libexslt
   TITLE:=Gnome XSLT xsltproc Utility
   URL:=http://xmlsoft.org/XSLT/
 endef
@@ -46,17 +57,14 @@ define Package/xsltproc/description
        XSLT XML transformation utility
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-python \
-               --without-crypto \
-               --without-debug \
-               --without-mem-debug \
-               --without-debugger \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --without-python \
+       --without-crypto \
+       --without-debug \
+       --without-mem-debug \
+       --without-debugger \
 
 TARGET_CFLAGS += $(FPIC)
 
@@ -98,6 +106,13 @@ define Package/libxslt/install
                $(1)/usr/lib/
 endef
 
+define Package/libexslt/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libexslt.so.* \
+               $(1)/usr/lib/
+endef
+
 define Package/xsltproc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
@@ -106,4 +121,5 @@ define Package/xsltproc/install
 endef
 
 $(eval $(call BuildPackage,libxslt))
+$(eval $(call BuildPackage,libexslt))
 $(eval $(call BuildPackage,xsltproc))