Add libpthread-stubs and xcbproto.
[packages.git] / libs / librsync / Makefile
index 59c8f92..dc8f1a8 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/librsync
 PKG_MD5SUM:=24cdb6b78f45e0e83766903fd4f6bc84
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,11 +22,13 @@ define Package/librsync
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=implementation of the rolling-checksum algorithm
-  DESCRIPTION:=\
-       librsync implements the rolling-checksum algorithm of remote file\\\
-       synchronization that was popularized by the rsync utility and is\\\
-       used in rproxy. This algorithm transfers the differences between 2\\\
-       files without needing both files on the same system.
+endef
+
+define Package/librsync/description
+       librsync implements the rolling-checksum algorithm of remote file
+       synchronization that was popularized by the rsync utility and is
+       used in rproxy. This algorithm transfers the differences between 2
+       files without needing both files on the same system.
 endef
 
 define Build/Configure
@@ -40,6 +38,8 @@ define Build/Configure
        );
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -47,16 +47,10 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/librsync{,-config}.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/librsync{,-config}.h \
-               $(STAGING_DIR)/usr/lib/librsync.{a,so*}
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/librsync{,-config}.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/librsync/install