packages: update alsa-lib to 1.0.27.2
[packages.git] / libs / libogg / Makefile
index 800302c..883f0ce 100644 (file)
@@ -1,24 +1,28 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libogg
-PKG_VERSION:=1.1.3
-PKG_RELEASE:=2
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ogg/
-PKG_FIXUP:=libtool
-PKG_MD5SUM:=eaf7dc6ebbff30975de7527a80831585
+PKG_MD5SUM:=84a35715170f2cd4c77a4448772b95d5
 
-include $(INCLUDE_DIR)/package.mk
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
 
-PKG_INSTALL=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
 
 define Package/libogg
   SECTION:=libs
@@ -48,7 +52,7 @@ endef
 
 define Package/libogg/install
        $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libogg))