[packages] make libintl and libiconv stub/full implementations switchable, use the...
[packages.git] / libs / libiconv / Makefile
index 80179f0..bc91c75 100644 (file)
@@ -1,21 +1,24 @@
 #
 # Copyright (C) 2010 OpenWrt.org
 #
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# This Makefile and the code shipped in src/ is free software, licensed
+# under the GNU Lesser General Public License, version 2.1 and later.
+# See src/COPYING for more information.
+#
+# Refer to src/COPYRIGHT for copyright statements on the source files.
 #
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libiconv
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Stub header for the GNU Character set conversion library
+  TITLE:=Tiny drop-in replacement for the GNU Character set conversion library
 endef
 
 define Build/Prepare
@@ -32,11 +35,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/libiconv.a $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/libiconv-stub/lib
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/libiconv.a $(1)/usr/lib/libiconv-stub/lib/
 
-       $(INSTALL_DIR) $(1)/usr/include
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/include/iconv.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/libiconv-stub/include
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/include/iconv.h $(1)/usr/lib/libiconv-stub/include/
 
        $(INSTALL_DIR) $(1)/usr/share/aclocal
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/m4/* $(1)/usr/share/aclocal/