use Build/Configure/Default macro, Makefile cleanup
[packages.git] / libs / libgcrypt / Makefile
index 365d085..0f8c019 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=libgcrypt
 PKG_VERSION:=1.2.1
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.gnupg.org/gcrypt/libgcrypt/
 PKG_MD5SUM:=b6d3217c9333c520fe54d2e8dc5e60ec
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -27,63 +27,31 @@ define Package/libgcrypt
   CATEGORY:=Libraries
   DEPENDS:=+libgpg-error
   TITLE:=GNU crypto library
-  DESCRIPTION:=The GNU crypto library.\\\
-    This is a general purpose cryptographic library based on the code from \\\
-    GnuPG. It provides functions for all cryptograhic building blocks: \\\
-    symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash \\\
-    algorithms (MD4, MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all \\\
-    hash algorithms), public key algorithms (RSA, ElGamal, DSA), large \\\
-    integer functions, random numbers and a lot of supporting functions.
+  DESCRIPTION:=\
+       This is a general purpose cryptographic library based on the code from \\\
+       GnuPG. It provides functions for all cryptograhic building blocks: \\\
+       symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash \\\
+       algorithms (MD4, MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all \\\
+       hash algorithms), public key algorithms (RSA, ElGamal, DSA), large \\\
+       integer functions, random numbers and a lot of supporting functions.
   URL:=http://directory.fsf.org/security/libgcrypt.html
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --disable-asm \
-                       --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --disable-asm \
+               --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libgcrypt/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(STAGING_DIR)/usr/bin/
@@ -103,4 +71,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/share/aclocal/libgcrypt.m4
 endef
 
+define Package/libgcrypt/install
+       install -d -m0755 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libgcrypt))