[package] updpate syslog-ng3 to 3.0.5, add support for logging kernel messages, patch...
[packages.git] / libs / libelf / Makefile
index 1c80c69..f7d5555 100644 (file)
@@ -1,24 +1,19 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libelf
-PKG_VERSION:=0.8.8
+PKG_VERSION:=0.8.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.mr511.de/software/
-PKG_MD5SUM:=be84e553686dd50c8b6d520f86f46521
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=e21f8273d9f5f6d43a59878dc274fec7
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,22 +21,22 @@ define Package/libelf
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=ELF object file access library
-  URL:=http://www.stud.uni-hannover.de/~michael/software/
+  URL:=http://www.mr511.de/software/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --enable-elf64=yes \
-               , \
-               mr_cv_target_elf=yes \
-               libelf_64bit=yes \
-               libelf_cv_struct_elf64_ehdr=yes \
-               libelf_cv_type_elf64_addr=no \
-               libelf_cv_struct_elf64_rel=yes \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --enable-elf64=yes \
+
+CONFIGURE_VARS += \
+       mr_cv_target_elf=yes \
+       libelf_64bit=yes \
+       libelf_cv_struct_elf64_ehdr=yes \
+       libelf_cv_type_elf64_addr=no \
+       libelf_cv_struct_elf64_rel=yes \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -50,16 +45,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libelf* $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/libelf* \
-               $(STAGING_DIR)/usr/lib/libelf.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libelf* $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libelf.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libelf/install