[package] updpate syslog-ng3 to 3.0.5, add support for logging kernel messages, patch...
[packages.git] / libs / libelf / Makefile
index 1404ccc..f7d5555 100644 (file)
@@ -1,20 +1,19 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libelf
-PKG_VERSION:=0.8.8
+PKG_VERSION:=0.8.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.mr511.de/software/
-PKG_MD5SUM:=be84e553686dd50c8b6d520f86f46521
+PKG_MD5SUM:=e21f8273d9f5f6d43a59878dc274fec7
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,9 +21,11 @@ define Package/libelf
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=ELF object file access library
-  URL:=http://www.stud.uni-hannover.de/~michael/software/
+  URL:=http://www.mr511.de/software/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -44,20 +45,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libelf* $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libelf.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/libelf* \
-               $(STAGING_DIR)/usr/lib/libelf.{a,so*}
-endef
-
 define Package/libelf/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf.so.* $(1)/usr/lib/