ntripserver: pass our CFLAGS
[packages.git] / libs / libdirectfb / Makefile
index 42f216a..13b02e4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,22 +13,25 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.directfb.org/downloads/Core/DirectFB-1.4
+PKG_MD5SUM:=e4376c6c5b8e27d735edb7f62a7a8e86
 
-PKG_INSTALL:=1
+PKG_LICENSE:=LGPLv2.1
+PKG_LICENSE_FILES:=COPYING
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/DirectFB
+define Package/directfb
     TITLE:=DirectFB
     SECTION:=libs
     CATEGORY:=Libraries
     URL:=http://directfb.org
-    DEPENDS:=+libpng +libjpeg +libpthread +libfreetype
+    DEPENDS:=+libpng +libjpeg +libpthread +libfreetype +libsysfs
 endef
 
-define Package/DirectFB/description
+define Package/directfb/description
     DirectFB is a thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system with support for translucent windows and multiple display layers, not only on top of the Linux Framebuffer Device. It is a complete hardware abstraction layer with software fallbacks for every graphics operation that is not supported by the underlying hardware.
 endef
 
@@ -74,10 +77,11 @@ define Build/InstallDev
                $(1)/usr/lib/
 endef
 
-define Package/DirectFB/install
+define Package/directfb/install
        $(INSTALL_DIR) \
                $(1)/usr/bin \
                $(1)/usr/lib \
+               $(1)/usr/share/directfb-1.4.2 \
                $(1)/usr/lib/directfb-1.4-0/interfaces/IDirectFBFont \
                $(1)/usr/lib/directfb-1.4-0/interfaces/IDirectFBImageProvider \
                $(1)/usr/lib/directfb-1.4-0/interfaces/IDirectFBVideoProvider \
@@ -88,6 +92,9 @@ define Package/DirectFB/install
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin/
        $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/directfb-1.4.2/* \
+               $(1)/usr/share/directfb-1.4.2/
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/lib{direct,fusion}*.so* \
                $(1)/usr/lib/
        $(CP) \
@@ -111,4 +118,4 @@ define Package/DirectFB/install
 endef
 
 $(eval $(call Feature,DirectFB))
-$(eval $(call BuildPackage,DirectFB))
+$(eval $(call BuildPackage,directfb))