[packages] libart: remove private libtool copy
[packages.git] / libs / libart / Makefile
index 9fad21f..d93d7e5 100644 (file)
@@ -1,24 +1,26 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libart
-PKG_VERSION:=2.3.17
+PKG_VERSION:=2.3.21
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3
-PKG_MD5SUM:=f1f6b3e5490f382535dccb288f5d8b14
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)_lgpl/2.3
+PKG_MD5SUM:=08559ff3c67fd95d57b0c5e91a6b4302
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_lgpl-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=aclocal.m4 ltmain.sh
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,46 +28,43 @@ define Package/libart
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An high-performance 2D graphics library
-  DESCRIPTION:=\
-       A library of functions for 2D graphics supporting a superset of the \\\
-       PostScript imaging model, designed to be integrated with graphics, artwork, \\\
-       and illustration programs. It is written in optimized C, and is fully \\\
-       compatible with C++. With a small footprint of 10,000 lines of code, it is \\\
-       especially suitable for embedded applications.
   URL:=http://www.levien.com/libart/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
+define Package/libart/description
+ A library of functions for 2D graphics supporting a superset of the
+ PostScript imaging model, designed to be integrated with graphics,
+ artwork, and illustration programs. It is written in optimized C, and
+ is fully compatible with C++. With a small footprint of 10,000 lines of
+ code, it is especially suitable for embedded applications.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               HOSTCC="$(HOSTCC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
+TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libart2-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libart-2.0 $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-endef
+       $(INSTALL_DIR) $(2)/bin $(1)/usr/include $(1)/usr/lib/pkgconfig
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/libart2-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/libart2-config
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libart-2.0 \
+                       $(1)/usr/include/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,a,so*} \
+               $(1)/usr/lib/
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libart2-config \
-               $(STAGING_DIR)/usr/include/libart-2.0 \
-               $(STAGING_DIR)/usr/lib/libart_lgpl_2.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libart/install