[package] wide-dhcpv6: improve user DUID handling
[packages.git] / libs / libart / Makefile
index eb8fed8..caebc56 100644 (file)
@@ -1,24 +1,26 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libart
-PKG_VERSION:=2.3.19
+PKG_VERSION:=2.3.21
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3
-PKG_MD5SUM:=a2992b830295132dae2bf85d1156e48e
+PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)_lgpl/2.3
+PKG_MD5SUM:=08559ff3c67fd95d57b0c5e91a6b4302
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_lgpl-$(PKG_VERSION)
+
 PKG_FIXUP:=libtool
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libart
@@ -29,30 +31,39 @@ define Package/libart
 endef
 
 define Package/libart/description
-       A library of functions for 2D graphics supporting a superset of the 
-       PostScript imaging model, designed to be integrated with graphics, artwork, 
-       and illustration programs. It is written in optimized C, and is fully 
-       compatible with C++. With a small footprint of 10,000 lines of code, it is 
      especially suitable for embedded applications.
+ A library of functions for 2D graphics supporting a superset of the
+ PostScript imaging model, designed to be integrated with graphics,
+ artwork, and illustration programs. It is written in optimized C, and
+ is fully compatible with C++. With a small footprint of 10,000 lines of
code, it is especially suitable for embedded applications.
 endef
 
 CONFIGURE_ARGS += \
        --enable-shared \
-       --enable-static
+       --enable-static \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               HOSTCC="$(HOSTCC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libart2-config $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libart-2.0 $(1)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(2)/bin $(1)/usr/include $(1)/usr/lib/pkgconfig
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/libart2-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/libart2-config
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libart-2.0 \
+                       $(1)/usr/include/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,a,so*} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libart/install