sox: moved to github
[packages.git] / libs / gsm / Makefile
index 3b8c67c..111be2d 100644 (file)
@@ -15,6 +15,9 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://user.cs.tu-berlin.de/~jutta/gsm/
 PKG_MD5SUM:=c1ba392ce61dc4aff1c29ea4e92f6df4
 
+PKG_LICENSE:=FREE
+PKG_LICENSE_FILES:=COPYRIGHT
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.0-pl13
 
 include $(INCLUDE_DIR)/package.mk
@@ -25,9 +28,9 @@ define Package/gsm/Default
 endef
 
 define Package/gsm/description/Default
- An implementation of the European GSM 06.10 provisional standard 
- for full-rate speech transcoding, prI-ETS 300 036, which uses 
- RPE/LTP (residual pulse excitation/long term prediction) coding 
+ An implementation of the European GSM 06.10 provisional standard
+ for full-rate speech transcoding, prI-ETS 300 036, which uses
+ RPE/LTP (residual pulse excitation/long term prediction) coding
  at 13 kbit/s.
 endef
 
@@ -63,8 +66,6 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \