[package] add missing libexslt depdency to xsltproc (#5922)
[packages.git] / libs / gd / Makefile
index a7583ea..2ba3d29 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -41,13 +40,19 @@ CONFIGURE_ARGS += \
        --without-freetype \
        --with-jpeg=$(STAGING_DIR)/usr \
        --with-png=$(STAGING_DIR)/usr \
-       --without-xpm
+       --without-xpm \
+       --without-iconv
 
 CONFIGURE_VARS += \
        LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
 
 TARGET_CFLAGS += $(FPIC)
 
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
+       $(call Build/Configure/Default)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -55,13 +60,13 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/entities.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gd{,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx}.h \
                $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,so*} $(1)/usr/lib/
        $(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/gdlib-config
 endef