[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[packages.git] / libs / faad2 / Makefile
index d1cad4d..b4170d6 100644 (file)
@@ -56,6 +56,10 @@ $(call Package/faad2/Default/description)
 endef
 
 define Build/Configure
+       # This replacement were do according to many comments on the web because of gcc 3.4.5 version (.6 included).-
+       # wich doesn't recognices the -iquote parameter to AM_CFLAGS
+       ($(SED) 's,-iquote $$$$(top_srcdir),-I$$$$(top_srcdir),g' $(PKG_BUILD_DIR)/libfaad/Makefile.am; \
+       $(SED) 's,-iquote $$$$(top_srcdir),-I$$$$(top_srcdir),g' $(PKG_BUILD_DIR)/libfaad/Makefile.in);
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                autoreconf -vif \
        );
@@ -74,9 +78,9 @@ MAKE_FLAGS += \
        all install \
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfaad.{a,so*} $(1)/usr/lib/
 endef