[package] add cyassl (moved from packages feed, required by uhttpd-mod-tls)
[packages.git] / libs / cyassl / Makefile
diff --git a/libs/cyassl/Makefile b/libs/cyassl/Makefile
deleted file mode 100644 (file)
index af4bc26..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=cyassl
-PKG_VERSION:=1.4.0
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
-PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=037397c7df84b9a12e614bf46135df1c
-
-PKG_FIXUP:=libtool
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libcyassl
-  SECTION:=libs
-  SUBMENU:=SSL
-  CATEGORY:=Libraries
-  DEPENDS:=+zlib
-  TITLE:=CyaSSL library
-  URL:=http://www.yassl.com/
-endef
-
-define Package/libcyassl/description
-CyaSSL is an SSL library optimized for small footprint, both on disk and for
-memory use.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --without-zlib \
-       --enable-singleThreaded
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
-endef
-
-define Package/libcyassl/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.so* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libcyassl))