[packages] liboil: don't build tools, docs and examples
[packages.git] / libs / classpath / Makefile
index 0a43a5c..084fbde 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=classpath
 PKG_VERSION:=0.98
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/classpath
 PKG_MD5SUM:=90c6571b8b0309e372faa0f9f6255ea9
 
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/classpath
@@ -22,26 +25,24 @@ define Package/classpath
   CATEGORY:=Libraries
   TITLE:=GNU Classpath
   URL:=http://www.gnu.org/software/classpath/
-  MAINTAINER:=Roberto Riggio (roberto.riggio@create-net.org)
+  MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
+  DEPENDS:=@BROKEN
 endef
 
-define Package/classpath/Description 
+define Package/classpath/Description
        GNU Classpath, Essential Libraries for Java, is a GNU project 
        to create free core class libraries for use with virtual 
        machines and compilers for the java programming language.
-endef 
-
-CONFIGURE_ARGS+= \
-       --with-javac \
-       --enable-jni \
-       --disable-gtk-peer \
-       --disable-gconf-peer \
-       --disable-plugin \
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               all install
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --with-javac \
+               --enable-jni \
+               --disable-gtk-peer \
+               --disable-gconf-peer \
+               --disable-plugin \
+       )
 endef
 
 define Package/classpath/install