packages/gdbm: fix whitespaces
[packages.git] / libs / avahi / Makefile
index 9adf415..5a13efe 100644 (file)
@@ -8,20 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 ifeq ($(BUILD_VARIANT),dbus)
-PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-dbus/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)/dbus/$(PKG_NAME)-$(PKG_VERSION)
+PKG_ALT_DIR=$(BUILD_DIR)/$(PKG_NAME)/nodbus/$(PKG_NAME)-$(PKG_VERSION)
 else
-PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-nodbus/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)/nodbus/$(PKG_NAME)-$(PKG_VERSION)
+PKG_ALT_DIR=$(BUILD_DIR)/$(PKG_NAME)/dbus/$(PKG_NAME)-$(PKG_VERSION)
 endif
 
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.30
-PKG_RELEASE:=4
+PKG_VERSION:=0.6.31
+PKG_RELEASE:=5
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=e4db89a2a403ff4c47d66ac66fad1f43
+PKG_MD5SUM:=2f22745b8f7368ad5a0a3fddac343f2d
 
 PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host libpthread dbus
 
@@ -43,11 +45,11 @@ define Package/avahi/Default
 endef
 
 define Package/avahi/Default/description
- Avahi is an mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) 
- implementation (library). It facilitates 
- service discovery on a local network -- this means that 
+ Avahi is an mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf)
+ implementation (library). It facilitates
+ service discovery on a local network -- this means that
  you can plug your laptop or computer into a network and
- instantly be able to view other people who you can chat with, 
+ instantly be able to view other people who you can chat with,
  find printers to print to or find files being shared.
  This kind of technology is already found in MacOS X
  (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
@@ -58,7 +60,7 @@ define Package/libavahi
   $(call Package/avahi/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libdaemon +libpthread +libgdbm
+  DEPENDS:=+libpthread +SSP_SUPPORT:libssp
   TITLE+= (library)
 endef
 
@@ -68,8 +70,8 @@ $(call Package/avahi/Default/description)
  The libavahi package contains the mDNS/DNS-SD shared libraries,
  used by other programs. Specifically, it provides
  libavahi-core and libavahi-common libraries.
- By default, it is compiled without D-Bus support,
- i.e. the --disable-dbus compilation flag is set.
+ By default, it is built without D-Bus support,
+ i.e. the --disable-dbus configuration flag is set.
  To enable D-Bus support, select the package
  libavahi-dbus-support.
 endef
@@ -84,9 +86,9 @@ endef
 define Package/avahi-autoipd/description
 $(call Package/avahi/Default/description)
  .
- This package implements IPv4LL, "Dynamic Configuration of IPv4 Link-Local 
- Addresses" (IETF RFC3927), a protocol for automatic IP address configuration 
- from the link-local 169.254.0.0/16 range without the need for a central 
+ This package implements IPv4LL, "Dynamic Configuration of IPv4 Link-Local
+ Addresses" (IETF RFC3927), a protocol for automatic IP address configuration
+ from the link-local 169.254.0.0/16 range without the need for a central
  server. It is primarily intended to be used in ad-hoc networks which lack a
  DHCP server.
 endef
@@ -94,7 +96,11 @@ endef
 define Package/avahi-daemon
   $(call Package/avahi/Default)
   SUBMENU:=IP Addresses and Names
-  DEPENDS:=+libavahi +libexpat
+  ifeq ($(BUILD_VARIANT),dbus)
+  DEPENDS:=+libavahi +libexpat +librt +libdaemon +libdbus
+  else
+  DEPENDS:=+libavahi +libexpat +librt +libdaemon
+  endif
   TITLE+= (daemon)
 endef
 
@@ -113,7 +119,7 @@ endef
 define Package/avahi-dnsconfd
   $(call Package/avahi/Default)
   SUBMENU:=IP Addresses and Names
-  DEPENDS:=+libavahi
+  DEPENDS:=+libavahi +libdaemon
   TITLE:=A Unicast DNS server from mDNS/DNS-SD configuration daemon
 endef
 
@@ -138,10 +144,10 @@ define Package/libavahi-dbus-support/description
 $(call Package/libavahi/description)
  .
  The libavahi-dbus-support package enables
- D-Bus support in libavahi, needed to support
+ D-Bus support in avahi, needed to support
  the libavahi-client library and avahi-utils.
- Selecting this package modifies the contents of the
libavahi package by setting the --enable-dbus compilation flag;
+ Selecting this package modifies the build configuration
so that avahi packages are built with support for D-BUS enabled;
  it does not generate a separate binary of its own.
  It also automatically adds the D-Bus package to the build.
  libavahi-dbus-support is selected automatically if you select
@@ -168,7 +174,7 @@ endef
 define Package/avahi-utils
   $(call Package/avahi/Default)
   SUBMENU:=IP Addresses and Names
-  DEPENDS:=+libavahi-client
+  DEPENDS:=+libavahi-client +libgdbm
   TITLE+= (utilities)
 endef
 
@@ -228,11 +234,12 @@ CONFIGURE_ARGS += \
        --enable-dbus
 else
 CONFIGURE_ARGS += \
-       --disable-dbus  
+       --disable-dbus
 endif
 
 CONFIGURE_VARS+= \
        CFLAGS="$$$$CFLAGS -DNDEBUG -DDISABLE_SYSTEMD" \
+       ac_cv_header_sys_capability_h=no \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
@@ -244,16 +251,20 @@ define Build/InstallDev
 endef
 
 define Package/libavahi-dbus-support/install
-       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/etc/dbus-1/system.d
+       $(CP) $(PKG_INSTALL_DIR)/etc/dbus-1/system.d/* $(1)/etc/dbus-1/system.d
 endef
 
 define Package/libavahi/install
+       # The next line removes the ".build" file from the "other" build.
+       # The effect is that, if the other build is re-selected in the future,
+       # the build system will be forced to replace all the code in the
+       # installer packages, removing anything from the current build.
+       # "Other" means this: if the current build is "dbus", the other is "nodebus",
+       # and if the current build is "nodbus", the other is "dbus".
+       $(RM) -f $(PKG_ALT_DIR)/.built
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.so.* $(1)/usr/lib/
-ifeq ($(BUILD_VARIANT),dbus)
-       $(INSTALL_DIR) $(1)/etc/dbus-1/system.d
-       $(CP) $(PKG_INSTALL_DIR)/etc/dbus-1/system.d/* $(1)/etc/dbus-1/system.d
-endif
 endef
 
 define Package/libavahi-client/install
@@ -299,4 +310,3 @@ $(eval $(call BuildPackage,libavahi))
 $(eval $(call BuildPackage,avahi-autoipd))
 $(eval $(call BuildPackage,avahi-daemon))
 $(eval $(call BuildPackage,avahi-dnsconfd))
-