[packages] Use default templates instead of custom reimplementations where applicable
[packages.git] / libs / avahi / Makefile
index ee4373a..3ca330d 100644 (file)
@@ -1,6 +1,5 @@
 #
-
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.23
-PKG_RELEASE:=2
+PKG_VERSION:=0.6.25
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=aab1a304851d8145ea5f6a85c10af9e9
+PKG_MD5SUM:=a83155a6e29e3988f07e5eea3287b21e
+
+PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host
 
-PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -41,12 +43,12 @@ define Package/libavahi
   $(call Package/avahi/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libdaemon +libpthread
+  DEPENDS:=+libdaemon +libpthread +libgdbm
   TITLE+= (library)
 endef
 
 define Package/libavahi/description
-$(call Package/avahi/Default/description) 
+$(call Package/avahi/Default/description)
  .
  This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
@@ -99,7 +101,8 @@ $(call Package/avahi/Default/description)
  in a DHCP-like fashion. Especially useful on IPv6.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -DGETTEXT_PACKAGE
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
@@ -142,20 +145,18 @@ endif
 
 CONFIGURE_VARS+= \
        CFLAGS="$$$$CFLAGS -DNDEBUG" \
-       $(if $(CONFIG_LINUX_2_4),ac_cv_header_sys_inotify_h=no)
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
+       $(call Build/Configure/Default)
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-{common,core} $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(1)/usr/lib/pkgconfig/
 endef
 
@@ -195,7 +196,3 @@ $(eval $(call BuildPackage,avahi-autoipd))
 $(eval $(call BuildPackage,avahi-daemon))
 $(eval $(call BuildPackage,avahi-dnsconfd))
 
-$(eval $(call RequireCommand,intltool-update, \
-       $(PKG_NAME) requires intltool >= 0.35.0 \
-))
-