packages/ruby: fix whitespaces
[packages.git] / lang / ruby / Makefile
index c85aa88..7f5acf3 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ruby
-PKG_LIBVER:=1.9.1
-PKG_VERSION:=$(PKG_LIBVER)-p376
-PKG_RELEASE:=2
+PKG_VERSION:=1.9.3-p484
+PKG_RELEASE:=1
+
+PKG_LIBVER:=1.9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/1.9/
-PKG_MD5SUM:=e019ae9c643c5efe91be49e29781fb94
+PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/$(PKG_LIBVER)/
+PKG_MD5SUM:=03f5b08804927ceabe5122cb90f5d0a9
 
 PKG_BUILD_DEPENDS:=ruby/host
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/ruby/Default
   SUBMENU:=Ruby
@@ -37,9 +42,9 @@ define Package/ruby/Default
 endef
 
 define Package/ruby/Default/description
- Ruby is the interpreted scripting language for quick and  easy 
- object-oriented programming.  It has many features to process text files 
- and to do system management tasks (as in perl).  It is simple, 
+ Ruby is the interpreted scripting language for quick and  easy
+ object-oriented programming.  It has many features to process text files
+ and to do system management tasks (as in perl).  It is simple,
  straight-forward, and extensible.
 endef
 
@@ -59,6 +64,7 @@ $(call Package/ruby/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (shared library)
+  DEPENDS+= +libpthread +librt
 endef
 
 # Ongoing work to break up ruby's standard library into coherent pieces
@@ -67,7 +73,7 @@ endef
 define Package/ruby-core
 $(call Package/ruby/Default)
   TITLE:=Ruby standard libraries
-  DEPENDS:=ruby
+  DEPENDS:=ruby +libdb47 +libffi
 endef
 
 define Package/ruby-cgi
@@ -121,7 +127,7 @@ endef
 define Package/ruby-ncurses
 $(call Package/ruby/Default)
   TITLE:=Ruby support for ncurses
-  DEPENDS:=ruby +libncurses
+  DEPENDS:=ruby +libncurses +libncursesw
 endef
 
 define Package/ruby-nkf
@@ -196,6 +202,10 @@ $(call Package/ruby/Default)
   DEPENDS:=ruby +zlib
 endef
 
+HOST_CONFIGURE_ARGS += \
+       --disable-install-doc \
+       --disable-install-rdoc \
+       --disable-install-capi
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -203,23 +213,14 @@ CONFIGURE_ARGS += \
        --disable-rpath \
        --enable-ipv6 \
        --enable-wide-getaddrinfo \
-
-CONFIGURE_VARS += \
-       ac_cv_func_setpgrp_void=yes
+       --with-ruby-version=minor \
+       --with-iconv-dir=$(ICONV_PREFIX) \
 
 TARGET_LDFLAGS += -L$(PKG_BUILD_DIR)
 
 MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
-       SHELL="/bin/bash" \
-       all install
-
-define Build/Prepare
-$(call Build/Prepare/Default)
-       ( cd $(PKG_BUILD_DIR) ; \
-               autoconf ; \
-       )
-endef
+       SHELL="/bin/bash"
 
 define Package/ruby/install
        $(INSTALL_DIR) $(1)/usr/bin
@@ -298,7 +299,7 @@ define Package/ruby-core/install
                $(1)/usr/lib/ruby/$(PKG_LIBVER)/yaml \
                $(1)/usr/lib/ruby/$(PKG_LIBVER)/yaml.rb \
                $(1)/usr/lib/ruby/$(PKG_LIBVER)/*/syck.so \
-       
+
        find $(1) -name '*.h' | xargs rm -f
 endef
 
@@ -381,7 +382,6 @@ define Package/ruby-openssl/install
                usr/lib/ruby/$(PKG_LIBVER)/*/openssl.so \
                usr/lib/ruby/$(PKG_LIBVER)/drb/ssl.rb \
                usr/lib/ruby/$(PKG_LIBVER)/net/https.rb \
-               usr/lib/ruby/$(PKG_LIBVER)/webrick/ssl.rb \
        ) | ( cd $(1); $(TAR) -xf - )
 endef
 
@@ -404,8 +404,6 @@ endef
 define Package/ruby-readline/install
        ( cd $(PKG_INSTALL_DIR); $(TAR) -cf - \
                usr/lib/ruby/$(PKG_LIBVER)/*/readline.so \
-               usr/lib/ruby/$(PKG_LIBVER)/irb/completion.rb \
-               usr/lib/ruby/$(PKG_LIBVER)/irb/ext/save-history.rb \
        ) | ( cd $(1); $(TAR) -xf - )
 endef