[packages/python] partially revert commit 31092, apply changes for real now - stupid...
[packages.git] / lang / python / patches / 120-force-internal-modules-for-hashlib.patch
index ca29aa6..ad10a44 100644 (file)
@@ -4,26 +4,21 @@
 
 --- a/setup.py
 +++ b/setup.py
-@@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
+@@ -704,8 +704,7 @@ class PyBuildExt(build_ext):
  
-         #print 'openssl_ver = 0x%08x' % openssl_ver
+         min_openssl_ver = 0x00907000
+         have_any_openssl = ssl_incs is not None and ssl_libs is not None
+-        have_usable_openssl = (have_any_openssl and
+-                               openssl_ver >= min_openssl_ver)
++        have_usable_openssl = False
  
--        if (ssl_incs is not None and
--            ssl_libs is not None and
--            openssl_ver >= 0x00907000):
-+#        if (ssl_incs is not None and
-+#            ssl_libs is not None and
-+#            openssl_ver >= 0x00907000):
-+        if False:
-             # The _hashlib module wraps optimized implementations
-             # of hash functions from the OpenSSL library.
-             exts.append( Extension('_hashlib', ['_hashopenssl.c'],
-@@ -644,7 +645,8 @@ class PyBuildExt(build_ext):
+         if have_any_openssl:
+             if have_usable_openssl:
+@@ -730,7 +729,7 @@ class PyBuildExt(build_ext):
                              depends = ['md5.h']) )
-             missing.append('_hashlib')
  
--        if (openssl_ver < 0x00908000):
-+#        if (openssl_ver < 0x00908000):
+         min_sha2_openssl_ver = 0x00908000
+-        if COMPILED_WITH_PYDEBUG or openssl_ver < min_sha2_openssl_ver:
 +        if True:
              # OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
              exts.append( Extension('_sha256', ['sha256module.c']) )