[packages] python: Only python mini should install the python binary.
[packages.git] / lang / pygtk / Makefile
index d63c687..f593ad7 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -34,7 +33,7 @@ define Package/python-gtk
   CATEGORY:=Languages
   TITLE:=GTK bindings for python
   URL:=http://www.pygtk.org/
-  DEPENDS:=python-core +python-gobject +gtk2 +pycairo
+  DEPENDS:=+python-mini +python-gobject +gtk2 +pycairo @!LINUX_2_4
 endef
 
 define Package/python-gtk/description
@@ -86,7 +85,7 @@ define Package/python-gtk/install
 
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/gtk-2.0/gtk
        $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/gtk-2.0/gtk/*.{py,so} \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/gtk-2.0/gtk/*.py* \
                $(1)$(PYTHON_PKG_DIR)/gtk-2.0/gtk
 endef