[packages] ffmpeg: include/disable swresample where appropriate
[packages.git] / lang / pyevent / Makefile
index 0a48e49..d578e6e 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,20 +14,19 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pyevent.googlecode.com/files/
 PKG_MD5SUM:=584912c92d08bf005283fb29a47a6e4d
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
+$(call include_mk, python-package.mk)
 
 define Package/python-event
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Python interface to libevent
   URL:=http://code.google.com/p/pyevent/
-  DEPENDS:=python-core +libevent
+  DEPENDS:=+python-mini +libevent2
 endef
 
 define PyPackage/python-event/filespec
@@ -36,7 +34,8 @@ define PyPackage/python-event/filespec
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,., \
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                LIBEVENT_HOME="$(STAGING_DIR)/usr/lib" \
        )