packages/yapsnmp: fix whitespaces
[packages.git] / lang / php5 / patches / 950-Fix-dl-cross-compiling-issue.patch
index 81de7f8..216a518 100644 (file)
@@ -1,11 +1,14 @@
---- a/configure
-+++ b/configure
-@@ -15979,7 +15979,7 @@
-     ac_libs=$LIBS
-     LIBS="$LIBS -ldl"
-     if test "$cross_compiling" = yes; then
--  found=no
-+  found=$found
- else
-   cat > conftest.$ac_ext <<EOF
- #line 15986 "configure"
+--- a/configure.in
++++ b/configure.in
+@@ -453,7 +453,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
+ PHP_CHECK_FUNC(gethostbyaddr, nsl)
+ PHP_CHECK_FUNC(yp_get_default_domain, nsl)
+-PHP_CHECK_FUNC(dlopen, dl)
++PHP_ADD_LIBRARY(dl)
++PHP_DEF_HAVE(dlopen)
++PHP_DEF_HAVE(libdl)
++ac_cv_func_dlopen=yes
+ if test "$ac_cv_func_dlopen" = "yes"; then
+   AC_DEFINE(HAVE_LIBDL, 1, [ ])
+ fi