more perl packages
[packages.git] / lang / perl-www-curl / Makefile
diff --git a/lang/perl-www-curl/Makefile b/lang/perl-www-curl/Makefile
new file mode 100644 (file)
index 0000000..c834f31
--- /dev/null
@@ -0,0 +1,42 @@
+# $Id: Makefile 4033 2006-06-21 02:32:39Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=perl-www-curl
+PKG_VERSION:=4.00
+PKG_RELEASE:=1
+PKG_MD5SUM:=f34eb29f59a811869a4f77bfc0df2f5d
+
+PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT
+PKG_SOURCE:=WWW-Curl-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/WWW-Curl-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+include ../perl/perlmod.mk
+
+define Package/perl-www-curl
+SUBMENU:=Perl
+SECTION:=lang
+CATEGORY:=Languages
+TITLE:=Perl bindings to libcurl
+URL:=http://search.cpan.org/~crisb/WWW-Curl-3.02/
+DEPENDS:=libcurl perl
+endef
+
+define Build/Configure
+       $(call perlmod/Configure,$(STAGING_DIR)/usr/include,)
+endef
+
+define Build/Compile
+       $(call perlmod/Compile,,)
+endef
+
+define Package/perl-www-curl/install
+       $(call perlmod/Install,$(1),WWW/Curl WWW/Curl.pm auto/WWW/Curl)
+endef
+
+
+$(eval $(call BuildPackage,perl-www-curl))