Update rp-pppoe to 3.10, enable kernel server mode and install ppp plugin (#3800)
[packages.git] / lang / perl / Makefile
index 98f1435..7c3123a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,7 +21,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/perl/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,17 +32,12 @@ define Package/perl/Default
   URL:=http://www.perl.com/
 endef
 
-define Package/perl/Default/description
- Perl rocks
-endef
-
 define Package/microperl
 $(call Package/perl/Default)
   TITLE+=(minimal version)
 endef
 
-define Package/perl/description
-$(call Package/perl/Default/description)
+define Package/microperl/description
  A perl package without operating-specific functions such as readdir.
 endef
 
@@ -84,6 +78,12 @@ $(call Package/perl/Default)
   MAINTAINER:=Peter Colberg <peter@petercolberg.org>
 endef
 
+define Package/perl/description
+ Perl is a stable, cross platform programming language.
+ It is used for mission critical projects in the public and private sectors
+ and is widely used to program web applications of all needs.
+endef
+
 define Build/perl/Configure
        @echo
        @echo "===> Stage 1: Configure host perl"
@@ -179,7 +179,17 @@ endef
 endif
 $(eval $(Build/perl))
 
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
 $(eval $(call BuildPackage,microperl))
 $(eval $(call BuildPackage,perl))
 
+$(eval $(call RequireCommand,rsync, \
+       $(PKG_NAME) requires rsync installed on the host-system. \
+))
+
 -include perlbase.mk