packages: fold the IPv6 menu into Network
[packages.git] / ipv6 / totd / Makefile
index 8848b04..0a1dad5 100644 (file)
@@ -1,36 +1,34 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5329 2006-10-28 22:43:08Z nico $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=totd
 PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.pasta.cs.uit.no/pub/totd/
+PKG_SOURCE_URL:=http://www.dillema.net/software/totd
 PKG_MD5SUM:=7edaedae9f6aca5912dd6c123582cf08
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/totd
-  SECTION:=ipv6
-  CATEGORY:=IPv6
+  SECTION:=net
+  CATEGORY:=Network
   DEPENDS:=+kmod-ipv6
   TITLE:=Small DNS proxy that supports IPv6/IPv4 record translation
-  DESCRIPTION:=\
-       totd is a small DNS proxy nameserver which supports IPv6 and enable IPv6\\\
-       only sites to access IPv4 sites by using some translation mechanism such\\\
+  URL:=http://www.dillema.net/software/totd.html
+endef
+
+define Package/totd/description
+       totd is a small DNS proxy nameserver which supports IPv6 and enable IPv6
+       only sites to access IPv4 sites by using some translation mechanism such
        as NAT-PT, KAME faith, etc...
-  URL:=http://pasta.cs.uit.no/software/totd.html
 endef
 
 define Package/totd/conffiles
@@ -42,7 +40,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                all
 endef
 
@@ -55,4 +53,8 @@ define Package/totd/install
        $(INSTALL_BIN) ./files/totd.init $(1)/etc/init.d/totd
 endef
 
+define Package/totd/conffiles
+/etc/totd.conf
+endef
+
 $(eval $(call BuildPackage,totd))