fix KBUILD_VERBOSE if V is unset
[10.03/openwrt.git] / include / verbose.mk
index 58a20a2..16a75c0 100644 (file)
@@ -9,7 +9,10 @@
 NO_TRACE_MAKE:=$(MAKE) V=99
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=$(V)
+  KBUILD_VERBOSE=0
+  ifdef V
+    KBUILD_VERBOSE=$(V)
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)