UML target completed. Added ext2 target fs for use with uml images
[10.03/openwrt.git] / include / kernel.mk
index 2c5d093..318ca68 100644 (file)
@@ -28,6 +28,11 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/armeb/arm/' \
 )
 
+ifneq (,$(findstring uml,$(BOARD)))
+LINUX_KARCH="um"
+KERNEL_CROSS=
+endif
+
 KERNEL_BUILD_DIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 LINUX_DIR := $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)