backport the autoreconf fixup (not enabled by default unless the package makefile...
[10.03/openwrt.git] / include / autotools.mk
index e1535d0..245c768 100644 (file)
@@ -32,6 +32,7 @@ update_libtool_ucxx = \
        ) \
        $(call update_libtool_common)
 
+autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
 # prevent libtool from linking against host development libraries
 define libtool_fixup_libdir
@@ -48,6 +49,24 @@ define remove_version_check
        fi
 endef
 
+define autoreconf
+       (cd $(PKG_BUILD_DIR); \
+               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh || true; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               -B $(STAGING_DIR)/host/share/aclocal \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+               fi \
+       );
+endef
+
+ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf
+endif
+
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
   Hooks/Configure/Pre += update_libtool remove_version_check