iputils: move to trunk and add myself as maintainer
[packages.git] / devel / oprofile / Makefile
index 0166363..ff88eea 100644 (file)
@@ -8,32 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oprofile
-PKG_VERSION:=0.9.4
-PKG_RELEASE:=2
+PKG_VERSION:=0.9.7
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/oprofile/
-PKG_MD5SUM:=82b059379895cf125261d7d773465915
+PKG_MD5SUM:=8b5d1d9b65f84420bcc3234777ad3be3
 
 PKG_BUILD_DEPENDS:=binutils
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-define KernelPackage/oprofile
-  SUBMENU:=Other modules
-  TITLE:=OProfile profiling support
-  KCONFIG:=CONFIG_OPROFILE @!LINUX_2_4
-  FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
-  DEPENDS:=@KERNEL_PROFILING
-endef
-
-define KernelPackage/oprofile/description
-  Kernel module for support for oprofile system profiling.
-endef
-
 define Package/oprofile
   SECTION:=devel
   CATEGORY:=Development
@@ -46,6 +35,14 @@ define Package/oprofile/description
  A transparent low-overhead system-wide profiler.
 endef
 
+define Package/oprofile-utils
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=OProfile System Profiler (extra utilities)
+  URL:=http://oprofile.sourceforge.net
+  DEPENDS:=oprofile
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-kernel-support \
@@ -53,14 +50,29 @@ define Build/Configure
        )
 endef
 
+TARGET_CXXFLAGS += -fpermissive
 TARGET_LDFLAGS := -L$(STAGING_DIR)/usr/lib $(TARGET_LDFLAGS)
 
+define Package/oprofile-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/opannotate \
+               $(PKG_INSTALL_DIR)/usr/bin/oparchive \
+               $(PKG_INSTALL_DIR)/usr/bin/opgprof \
+               $(1)/usr/bin
+endef
+
 define Package/oprofile/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin
 
+       rm -f \
+               $(1)/usr/bin/opannotate \
+               $(1)/usr/bin/oparchive \
+               $(1)/usr/bin/opgprof
+
        $(INSTALL_DIR) $(1)/usr/lib/oprofile
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/oprofile/*.so* \
@@ -69,9 +81,9 @@ define Package/oprofile/install
        $(INSTALL_DIR) $(1)/usr/share/oprofile
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/share/oprofile/stl.pat \
-               $(PKG_INSTALL_DIR)/usr/share/oprofile/$(LINUX_KARCH) \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/$(patsubst x86,i386,$(LINUX_KARCH)) \
                $(1)/usr/share/oprofile/
 endef
 
 $(eval $(call BuildPackage,oprofile))
-$(eval $(call KernelPackage,oprofile))
+$(eval $(call BuildPackage,oprofile-utils))