[patchteam] - Corkscrew - new package - Signed-off-by: koniu <gkusnierz@gmail.com>
[packages.git] / devel / oprofile / Makefile
index ccdc2f9..2961e2d 100644 (file)
@@ -1,22 +1,23 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oprofile
 PKG_VERSION:=0.9.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/oprofile/
 PKG_MD5SUM:=82b059379895cf125261d7d773465915
+
+PKG_BUILD_DEPENDS:=binutils
+PKG_FIXUP:=libtool
 PKG_INSTALL:=1
-PKG_BUILD_DEPENDS:=libbfd
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -24,7 +25,7 @@ include $(INCLUDE_DIR)/kernel.mk
 define KernelPackage/oprofile
   SUBMENU:=Other modules
   TITLE:=OProfile profiling support
-  KCONFIG:=CONFIG_OPROFILE
+  KCONFIG:=CONFIG_OPROFILE @!LINUX_2_4
   FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
   DEPENDS:=@KERNEL_PROFILING
 endef
@@ -45,6 +46,14 @@ define Package/oprofile/description
  A transparent low-overhead system-wide profiler.
 endef
 
+define Package/oprofile-utils
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=OProfile System Profiler (extra utilities)
+  URL:=http://oprofile.sourceforge.net
+  DEPENDS:=oprofile
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-kernel-support \
@@ -52,12 +61,28 @@ define Build/Configure
        )
 endef
 
+TARGET_LDFLAGS := -L$(STAGING_DIR)/usr/lib $(TARGET_LDFLAGS)
+
+define Package/oprofile-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/opannotate \
+               $(PKG_INSTALL_DIR)/usr/bin/oparchive \
+               $(PKG_INSTALL_DIR)/usr/bin/opgprof \
+               $(1)/usr/bin
+endef
+
 define Package/oprofile/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin
 
+       rm -f \
+               $(1)/usr/bin/opannotate \
+               $(1)/usr/bin/oparchive \
+               $(1)/usr/bin/opgprof
+
        $(INSTALL_DIR) $(1)/usr/lib/oprofile
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/oprofile/*.so* \
@@ -65,9 +90,11 @@ define Package/oprofile/install
 
        $(INSTALL_DIR) $(1)/usr/share/oprofile
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/share/oprofile/* \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/stl.pat \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/$(LINUX_KARCH) \
                $(1)/usr/share/oprofile/
 endef
 
 $(eval $(call BuildPackage,oprofile))
+$(eval $(call BuildPackage,oprofile-utils))
 $(eval $(call KernelPackage,oprofile))