contrib/package, applications/luci-olsr: implement NatThreshold to minimize gateway...
[project/luci.git] / contrib / uci / Makefile
index 1b91519..b392787 100644 (file)
@@ -1,7 +1,7 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-UCI_VERSION  = 0.7.0
+UCI_VERSION  = 0.7.5
 UCI_SITE    = http://mirror2.openwrt.org/sources
 UCI_DIR     = uci-$(UCI_VERSION)
 UCI_FILE    = $(UCI_DIR).tar.gz
@@ -20,12 +20,13 @@ include ../../build/module.mk
 $(UCI_FILE):
        wget -O $@ "$(UCI_URL)" || rm -f $@
 
-$(UCI_PATCHDIR)/series:
-       (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-
 $(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
        tar xvfz $(UCI_FILE)
+       (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
+       [ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
+               patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
+       done < $(UCI_PATCHDIR)/series || true
        touch $@
 
 compile: $(UCI_DIR)/.prepared