[packages] htop: fix undefined references to rpl_malloc, rpl_realloc (#8997)
[packages.git] / admin / sudo / Makefile
index d9cc4c8..b5038af 100644 (file)
@@ -3,16 +3,17 @@
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sudo
-PKG_VERSION:=1.7.2p3
+PKG_VERSION:=1.7.4p4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.sudo.ws/sudo/dist/
-PKG_MD5SUM:=b4bb9a0ae896958b71e48ef91967cdcb
+PKG_SOURCE_URL:=http://www.sudo.ws/sudo/dist
+PKG_MD5SUM:=55d9906535d70a1de347cd3d3550ee87
 
 PKG_INSTALL:=1
 
@@ -26,10 +27,10 @@ define Package/sudo
 endef
 
 define Package/sudo/description
-Sudo (su "do") allows a system administrator to delegate authority to give
-certain users (or groups of users) the ability to run some (or all) commands as
-root or another user while providing an audit trail of the commands and their
-arguments.
+ Sudo (su "do") allows a system administrator to delegate authority to
+ give certain users (or groups of users) the ability to run some (or
+ all) commands as root or another user while providing an audit trail of
+ the commands and their arguments.
 endef
 
 define Package/sudo/conffiles
@@ -39,7 +40,9 @@ endef
 CONFIGURE_ARGS+= \
        --without-pam \
        --disable-pam-session \
-       --with-editor=/bin/vi
+       --with-editor=/bin/vi \
+       --without-lecture \
+       --disable-zlib
 
 CONFIGURE_VARS+= \
        sudo_cv_uid_t_len=10 \
@@ -54,6 +57,7 @@ define Package/sudo/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/sudoers $(1)/etc/
        chmod 0440 $(1)/etc/sudoers
+       $(INSTALL_DIR) $(1)/etc/sudoers.d
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sudo_noexec.so $(1)/usr/lib/
 endef