- update to Xorg X11R7.4 and reorganization of the xorg-section
[packages.git] / Xorg / lib / pango / Makefile
diff --git a/Xorg/lib/pango/Makefile b/Xorg/lib/pango/Makefile
new file mode 100644 (file)
index 0000000..3d756b2
--- /dev/null
@@ -0,0 +1,83 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+# $Id: Makefile 12845 2008-10-03 21:55:24Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pango
+PKG_VERSION:=1.20.5
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/1.20/
+PKG_MD5SUM:=052b60a12f6b2eb4f251ab961f2b2b84
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib
+
+define Package/pango
+  SECTION:=xorg-libs
+  CATEGORY:=Xorg
+  SUBMENU:=libraries
+  TITLE:=Text layout and rendering library
+  DEPENDS:=+cairo +glib2
+endef
+
+define Package/pango/description
+Pango is a library for layout and rendering of text, with an emphasis
+on internationalization. Pango can be used anywhere that text layout
+is needed; however, most of the work on Pango so far has been done using
+the GTK+ widget toolkit as a test platform. Pango forms the core of text
+and font handling for GTK+-2.x.
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,lib/pango/1.6.0/modules,include}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} \
+               $(1)/usr/lib
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pango/1.6.0/modules/*{.so*,la} \
+               $(1)/usr/lib/pango/1.6.0/modules/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/* \
+               $(1)/usr/include/
+endef
+
+define Package/pango/install
+       $(INSTALL_DIR) $(1)/usr/{lib/pango/1.6.0/modules,bin}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pango/1.6.0/modules/*.so* \
+               $(1)/usr/lib/pango/1.6.0/modules/
+
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/pango-querymodules \
+               $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/pango-querymodules.init $(1)/etc/init.d/pango-querymodules
+endef
+
+$(eval $(call BuildPackage,pango))