lots of package cleanups/fixes
[packages.git] / XOrg / lib / gtk-1.2.10 / Makefile
index cdc7d5c..4635acc 100644 (file)
@@ -13,7 +13,9 @@ PKG_VERSION:=1.2.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://gd.tuwien.ac.at/graphics/gimp/gtk/v1.2/
+PKG_SOURCE_URL:= \
+       ftp://ftp.gtk.org/pub/gtk/v1.2/ \
+       http://gd.tuwien.ac.at/graphics/gimp/gtk/v1.2/
 PKG_BUILD_DIR=$(BUILD_DIR)/gtk+-1.2.10
 
 include $(INCLUDE_DIR)/package.mk
@@ -25,8 +27,8 @@ CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
                --enable-static=yes
 
 EXTRA_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
-
-EXTRA_LDFLAGS+=-lnotimpl
+TARGET_CFLAGS+= -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
+EXTRA_LDFLAGS+=-lnotimpl -lglib -lgmodule
 
 define Package/gtk-1.2.10
   SECTION:=xorg-framework
@@ -54,9 +56,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-       $(SED) "s,libdirs=-L.*,libdirs=,g" $(1)/usr/bin/gtk-config
-       $(SED) "s,"libdir\=\'/usr/lib\'",libdir='$(1)/usr/lib\'," $(1)/usr/lib/lib{gtk,gdk}.la
+       $(INSTALL_DIR) $(2)/bin
+       mv $(1)/usr/bin/gtk-config $(2)/bin/
+       $(SED) "s,libdirs=-L.*,libdirs=,g" $(2)/bin/gtk-config
 endef
 
 $(eval $(call BuildPackage,gtk-1.2.10))