change default path for staging_dir.
[10.03/openwrt.git] / Makefile
index 8342bab..3d9bcb3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -69,9 +69,13 @@ package_install: toolchain
 # In this section, we need .config
 include .config.cmd
 
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
+world: $(DL_DIR) $(BUILD_DIR) configtest target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
 
-.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
+.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install configtest
+
+configtest:
+       -cp .config .config.test
+       -scripts/configtest.pl
 
 package_index:
        (cd $(PACKAGE_DIR); \
@@ -112,7 +116,7 @@ dirclean: clean
        rm -rf $(BUILD_DIR)
 
 distclean: clean
-       rm -rf $(STAMP_DIR) $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR)
+       rm -rf $(STAMP_DIR) $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) $(STAGING_DIR)
        rm -f .config* .tmpconfig.h
 
 sourceball: distclean