With eglibc needs to define -D_GNU_SOURCE in cflags to avoid following error:
authorMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:07:38 +0000 (11:07 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 29 Jan 2014 13:52:19 +0000 (13:52 +0000)
  CC      build-mips/sa/pton.o
src/sa/pton.c: In function 'net_inet_pton':
src/sa/pton.c:233:7: error: 'const struct in6_addr' has no member named 's6_addr32'
src/sa/pton.c:233:7: error: 'const struct in6_addr' has no member named 's6_addr32'
src/sa/pton.c:233:7: error: 'const struct in6_addr' has no member named 's6_addr32'

Signed-off-by: Mika Laitio <mika.laitio@nokia.com>
libs/re/Makefile

index c3cc27b..fbafd47 100644 (file)
@@ -28,6 +28,10 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+TARGET_CFLAGS += -D_GNU_SOURCE
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                HAVE_LIBRESOLV= \