FreeSWITCH:
authorMazi Lo <openwrt.mazilo@recursor.net>
Sat, 9 Aug 2014 04:33:39 +0000 (00:33 -0400)
committerMazi Lo <openwrt.mazilo@recursor.net>
Sat, 9 Aug 2014 04:33:39 +0000 (00:33 -0400)
  1. Bump to git HEAD e3e84a7820954195e8311be783a3e0cf9c1ba2ad.
  2. mod_enum and mod_erlang flagged as BROKEN (lacking dependencies).
  3. Fix ticket #17410 (error: recursive dependency detected!).

Signed-off-by: Mazi Lo <openwrt.mazilo@recursor.net>
libs/libsrtp/Makefile
net/freeswitch/patches/1128080-libs-sofia-sip-configure_gnu.patch [new file with mode: 0644]

index 3288447..9118f4f 100644 (file)
@@ -23,18 +23,45 @@ include $(INCLUDE_DIR)/package.mk
 TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += --disable-stdout --enable-syslog
 
-define Package/libsrtp
+define Package/libsrtp/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Secure Real-time Transport Protocol (SRTP) library
+  TITLE:=Secure Real-time Transport Protocol (SRTP)
   URL:=http://sourceforge.net/projects/srtp
   MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 endef
 
+define Package/libsrtp/Default/description
+  Open-source implementation of the Secure Real-time Transport
+  Protocol (SRTP) originally authored by Cisco Systems, Inc.
+  It is available under a BSD-style license.
+endef
+
+define Package/libsrtp
+  $(call Package/libsrtp/Default)
+  TITLE+= library
+endef
+
 define Package/libsrtp/description
-Open-source implementation of the Secure Real-time Transport
-Protocol (SRTP) originally authored by Cisco Systems, Inc.
-It is available under a BSD-style license.
+  $(call Package/libsrtp/Default/description)
+
+  This package ONLY contains shared libraries. For development
+  libraries, please install libsrtp-dev package.
+
+endef
+
+define Package/libsrtp-dev
+  $(call Package/libsrtp/Default)
+  TITLE+= development library
+  DEPENDS:=+libsrtp
+endef
+
+define Package/libsrtp-dev/description
+  $(call Package/libsrtp/Default/description)
+
+  This package contains ONLY include files, static libraries, and
+  pkgconfig files.
+
 endef
 
 define Build/InstallDev
@@ -47,8 +74,15 @@ endef
 
 define Package/libsrtp/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so.* \
-               $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so* $(1)/usr/lib/
+endef
+
+
+define Package/libsrtp-dev/install
+       $(INSTALL_DIR) $(1)/usr/{include,lib}
+       $(CP) $(PKG_INSTALL_DIR)/usr/include $(1)/usr/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.a $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsrtp))
+$(eval $(call BuildPackage,libsrtp-dev))
diff --git a/net/freeswitch/patches/1128080-libs-sofia-sip-configure_gnu.patch b/net/freeswitch/patches/1128080-libs-sofia-sip-configure_gnu.patch
new file mode 100644 (file)
index 0000000..73b6172
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/libs/sofia-sip/configure.gnu
++++ b/libs/sofia-sip/configure.gnu
+@@ -1,4 +1,4 @@
+ #! /bin/sh
+ srcpath=$(dirname $0 2>/dev/null )  || srcpath="." 
+-$srcpath/configure "$@" --with-pic --with-glib=no --disable-shared  --without-doxygen --disable-stun
++$srcpath/configure "$@" --with-pic --with-glib=no --disable-shared  --without-doxygen